Photoshop Compositing Basics

What is Compositing?

In a composite image, you combine multiple elements that weren’t originally photographed in the same scene. In a landscape photograph, you might replace the sky with one from another photo. Or you might create an add by mixing photographs, graphics, and text.

Figure 1A composite graphic

Figure 2 The graphic is made up of a red color fill layer in the back, the flower image, a mask that makes parts of the flower image transparent, and text.

This book concentrates on what to do in Photoshop to create a successful composite image. When you take all the technical jargon out of it, compositing is about separating a subject from its original background and dropping it into a
new image. But it isn’t as simple as following the steps in the software. To make the composite convincing, it has to be visually consistent. Before you even get the images out of your camera and into Photoshop, you’ll want both images to be consistent in terms of the angle and quality of light, as well as perspective. A background in drawing and painting help, because those visual skills help you synthesize a scene from scratch.

This short book assumes you already know the basics of using your computer and Photoshop. While the figures show Photoshop running in OS X, the steps work equally well in Photoshop in Windows. Where you see a keyboard shortcut, the OS X shortcut is followed by the Windows shortcut.

**How Does Compositing Work in Photoshop?**

If you’ve tried other photo or painting applications, you may already know that combining images can be as simple as pasting part of one image onto another. You can do that in Photoshop too, but the reason Photoshop strives to beyond simple copying and pasting is so that you have the flexibility and tools to achieve a truly professional result.

There are really only two major concepts behind compositing in Photoshop: Setting up each part of an image as a Photoshop layer, and then making parts of layers transparent. It’s the details that can make compositing seem challenging: exactly how you make selections and control transparency among layers.

**Set Up Each Element as a Different Layer**

Photoshop makes compositing easier by providing layers. With layers, you can keep different parts of an image as separate, distinct elements but display them as if they were a single image. Layers let you refine the composition until it’s perfect. For example, if you keep the images you combine on separate layers, you can move each image around the canvas until their positions are perfect.
You manage layers in the Layers panel, which lists layers with the frontmost layer at the top. You can change how they’re stacked by dragging layers up and down in the list, or by using menu commands or keyboard shortcuts. After clicking a layer in the Layers panel to select it, you can drag the layer around the document window independently of other layers.
How do you get layers in the first place? Simply dragging one document to another adds the first document as a layer in the second document. You can also create a new blank layer in the Layers panel and paint on it. You can also select an area on an existing layer and choose Layer > New > Layer via Copy. Other elements you create in Photoshop can be added as layers, such as a solid color, a gradient, a pattern, or editable text.

When you create a new layer, it’s empty until you fill it with something. Many Photoshop documents also have a layer named Background that appears in italics in the Layers panel. The Background layer is always opaque; you can’t erase it to transparency or change its order in the layer stack until you convert it to a non-background layer. To do this, double-click the Background layer, name it, and click OK. A shorter way to do this is to Option-click/Alt-click the Background layer, which immediately converts it to a normal layer and automatically names it.
Remove Unwanted Areas and Backgrounds

Either before or after you combine images, you’ll need to remove any areas that need to be transparent. Transparency is critical to compositing. Without it, you’d never see behind the top layer. When you remove a background, what you’re really doing is making unwanted areas transparent.

There’s more than one way to create a transparent area, depending on the effect you’re after. Opacity, blending modes, and layer blending options are different ways to create transparent areas by comparing the colors and tones of a layer with the layers behind it. For example, you can quickly make all white areas transparent in a single step by using layer blending options. If you want to specifically mark layer areas that you want to be transparent, you can create a mask for that layer.

![Figure 5 Original image, mask, and background removed by the mask](image)

You don’t always have to do this from scratch if an image or layer already has its own transparent areas. For example, if you simply paint on a blank layer, the parts you paint are the only areas that are opaque or partially opaque. The rest of the layer is transparent. If an area is completely transparent, Photoshop indicates it with a checkerboard pattern so that you can tell the difference between
When you use images from other sources such as a stock photo service or a catalog photographer, some objects you import might already be on a transparent background. If you want to save an image with a transparent background, first isolate the image from the background and then save it in a format that supports transparency. How you do that is covered in more detail later in this book.

When you create a type layer in Photoshop or draw in vector-based illustration software such as Adobe Illustrator, by default the objects exist on a transparent background, and they'll stay that way as long as the document is saved in a file format that supports transparency. Most vector-based file formats do support transparency.

It doesn’t matter whether you make backgrounds transparent before or after you combine them in a Photoshop document. If an image already contains a background you don’t have to do it in Photoshop, but if you have to remove a background in Photoshop that's easy to do.

A Quick Overview of Compositing with Photoshop

If the images you’re combining already have transparency, you can simply drag them into Photoshop and begin composing them on the canvas. That’s what I’ll cover in this section. If the images you want to use need to be isolated from their backgrounds, I talk about that in most of the rest of this book.

Organizing Files in Bridge or Lightroom

You might be used to bringing images into Photoshop by using the Open command. That’s fine for locating and opening one image, but it can be a tedious way to locate multiple images that you want to open and combine. It’s much faster to first organize your project in Adobe Bridge or Adobe Photoshop.
Lightroom where you can quickly view, sort, and visually organize multiple images. You can then drag multiple images directly into Photoshop, or use special commands in Bridge and Lightroom to open multiple images as a single layered Photoshop image in one step which I’ll talk about later.

Figure 7 Dragging multiple images from Bridge to Photoshop

If all of the images you want to use are already stored in the same folder, you can simply select them all and drag them into Photoshop from Bridge, Lightroom, or the desktop. If you still need to narrow down the set of images you want to use, the techniques in this section may help.

If you try some of the techniques in this section and you see a white rectangle behind any image you used, that means you still need to remove the background of that image and save it in a format that supports transparency. To do that, jump ahead to “Selecting Areas to Make Transparent” and “Creating Transparent Areas Using Masks.”

Comparing Images

Evaluating images side-by-side is a useful skill when selecting the images you want to use in a composite. Naturally, comparing images helps you see all of the images you want at the same time. It’s also great for helping you verify image consistency, such as whether shadows are going in the same direction. You can spot potential problems before going to the trouble of importing images into Photoshop. Both Bridge and Lightroom give you multiple ways to compare images.

There are a couple of ways to compare images in Bridge. The first way is Review Mode, which gives you a full-screen view of multiple images. Simply select
multiple images and choose View > Review Mode or press Command-B (Mac) or Ctrl-B (Windows). If you select one to four images, Review Mode shows them side-by-side. If you select more than four images, Review Mode displays them as a carousel that lets you cycle through the images.

![Figure 8: Four-image Review Mode in Bridge](image)

In Lightroom, Survey Mode is the quick and easy way to show multiple images at once. In the Grid mode or Filmstrip, select multiple images and then choose View > Survey or press N. Survey mode is a great way to see how well multiple images work as a set, especially on a larger monitor where you can eyeball the relative lighting, perspective, and sharpness of images you want to combine.

![Figure 9: Survey Mode in Lightroom](image)

Lightroom also has a two-image Compare mode, which is intended more for testing a single image against others to verify that it’s the one you want. In the Grid mode or Filmstrip, select multiple images and then choose View > Survey or press N.
Collecting Images

The images you want to use may be stored in different folders. If you want to work with all of the images in one place, you may be tempted to move or copy them all into the same folder. However, maintaining copies can make file organization more complicated and use up disk space unnecessarily. Instead, take advantage of the collections feature in Bridge and Lightroom. The great thing about collections is that they contain only references to files, not the files themselves, so that you can use a file in as many collections as you want while using very little additional disk space. Taking a file out of a collection doesn’t delete the file itself, only its listing in that collection; and it doesn’t delete the file from other collections. A collection can even be useful if the images you want to use are all in the same folder; for example, if you want to work with just five images out of a folder containing 200 images.

In Lightroom, you find Collections in the left panel stack in any module. To create a new collection, click the plus sign at the top left of the Collections panel heading, choose Create Collection, set options and name your collection. Then add any file from the Filmstrip or Grid view to that collection by dragging its thumbnail to the collection you created.

Figure 10 Compare Mode in Lightroom
If you want to organize multiple collections, create a collection set by clicking the same plus sign where you created a collection and choosing Create Collection Set. For example, you might create a collection set that contains the collections for an entire project (candidate images, final images, completed composites, and so on).

When you set a Lightroom collection as a **target collection**, you can add files to it with a single-key shortcut. Ctrl-click/right-click on a collection and choose Choose Set as Target Collection. With that set up, as you browse through files in Lightroom as soon as you see a file you want to use in your project you can simply press the B key to kick it into the target collection.

Bridge also has collections (Window > Collections Panel), but they aren’t quite as powerful as in Lightroom. You can still gather files from multiple folders and sequence them, but you must manually drag files into each collection. Bridge doesn’t have a Target Collection feature.

---

**Placing Images into Photoshop**

Bringing additional images into a Photoshop document is an essential step in compositing. When you drop an image into an existing Photoshop document, you might notice that it isn’t immediately available as an image. It has handles and can’t be edited with retouching tools. What’s up with that? The difference is that Photoshop treats a dragged-and-dropped image as a Smart Object, which is a good thing. It provides handles so that you can resize and reposition the imported image before finishing the import. Once you do that, just press Return or Enter to commit it to the document as a new Smart Object layer.
This behavior is the same as if you imported the image using the File > Place command. Feel free to import images that way as well; it’s just that you’ll probably find that drag-and-drop is both easier and more direct. Importing images with drag-and-drop especially streamlines your compositing workflow when you can already see the images you want on the desktop or in Bridge or Lightroom. Instead of having to navigate to those files in the Open dialog box, you simply drag them over.

A Smart Object has other advantages. For example, you can apply Smart Filters to them, which means you can go back and change filter settings at any time regardless of whether the Undo step for that filter is still available. Also, a Smart Object preserves more original image quality if you repeatedly transform (scale, rotate, distort) the image.

**Loading Multiple Files as Layers**

If you’re starting from Bridge or Lightroom, in one step you can open multiple selected images as separate layers into a single Photoshop document. This can save you a lot of time compared to manually dragging or importing files one by one into a Photoshop document. To do this:

- In Bridge, select the images and then choose Tools > Photoshop > Load Files into Photoshop Layers.
- In Lightroom, select multiple images in the Filmstrip or in Grid view, and then choose Photo > Edit In > Open as Layers in Photoshop.

**Dragging and Dropping From Other Photoshop Documents**

If you have two Photoshop documents open, you can drag a layer from one Photoshop document into another. In that case, the layer remains a layer when dropped into the second document and you can edit it immediately, but you also won’t have the benefits of working with a Smart Object.

You can drag more than one layer to another document. To keep multiple layers together as you transfer them, you can group them first (select the layers in the Layer panel and choose Layer > Group Layers). This helps preserve the stacking...
order of the layers you’re transferring when you drag them into a document that already has several layers. It’s also easier to drag a single group than to carefully select multiple layers and drag them all together.

![Figure 14 Grouping layers and then dragging the group](image)

**On to the Details**

Once you’ve got images or layers that are already set up on transparent backgrounds, putting them together in Photoshop is a simple matter of positioning them and arranging their stacking order in the Layers panel. For many projects, much of the labor actually goes into prepping each of the component images before they’re assembled into a composite. That’s why the rest of this book is about how you create the transparency that makes compositing possible.

**Creating Transparency Without Masks**

While many compositing projects depend on images that have their transparent areas marked by masks, sometimes you can achieve the effect you want without having to spend the time cutting out a mask. In Photoshop you can change the overall opacity of the layer, or use various methods to change the appearance and visibility of the areas of a layer by comparing its color values with the layers behind it. You can also think of the techniques in this section as ways to mask one image using another.

**Adjusting Opacity**

Layer opacity is pretty easy to understand: You simply make an entire layer more transparent. The Opacity value makes the entire layer equally transparent. In comparison, some of the alternatives discussed later can result in some parts of a layer being more transparent than others.
To change layer opacity, select a layer in the Layers panel and change the Opacity value. You can change the Opacity value in multiple ways:

- Enter a new value and press Return or Enter.
- Click the pop-up triangle next to the Opacity value and drag the slider.
- Without clicking the Opacity value, type a number. Typing a single-digit number from 1 to 9 sets a percentage from 10% to 90%, or you can type a two-digit number quickly to enter that value. Typing 0 sets Opacity to 100%.
- Command-drag/Ctrl-drag the Opacity value left or right. This is called “scrubbing the value and works in many places where you see a numeric value.

![Opacity control in the Options bar (top) applies only to brushes and retouching tools, while the Opacity control in the Layers panel (bottom) applies to layers.](image)

Apply careful when you’ve been using painting or retouching tools, because those also have an Opacity value that’s in the Options bar. If you press the keyboard shortcuts for setting Opacity, they’ll affect a tool first and the Layers panel second, so if you want to ensure that Opacity shortcuts affect only the Layers panel, first switch to a tool that doesn’t have an Opacity option. Take advantage of the single-key tool shortcuts to make sure the tool switch doesn’t take up any of your time. For example, simply press H to switch to the Hand tool and then press the Opacity shortcut you want.

**Applying Blending Modes**

Photoshop has a feature called **blending modes** that is kind of like a fancier form of transparency. Instead of making an entire layer equally transparent, the way an image is composited with the layers behind it depends on how the colors of the selected layer mathematically combine with the colors of the other layers.

If you aren’t sure whether you need to use a blending mode, one approach is to start by adjusting Opacity only. If you think that the appearance of the layer after adjusting Opacity is close to what you want but not quite, that’s a good clue that you might want to try a blending mode. The blending modes that are useful for compositing can produce effects that are more subtle or more dramatic than adjusting Opacity.
The blending modes that you get to choose from are actually different formulas that Photoshop uses to figure out how the top layer will look. The trick is to become familiar with what each blending mode does. If the following blending mode descriptions make your eyes glaze over, hang on—visual examples are coming up.

**How Blending Modes Think**

The biggest question anyone has when using blending modes is, “How do I know which blending mode will do what I want?” To find out, ask yourself the following questions:

- Do I want to alter the light areas of the underlying layers, the dark areas, or both? Many blending modes have a neutral color that doesn’t change the layers under it. For example, for the Lighten, Screen, Color Dodge, and Linear Dodge blending modes, black pixels on the applied layer don’t alter the same pixels on the underlying layer, and the farther an applied pixel is from black (that is, the lighter it is), the more it affects the underlying layer.

- For other blending modes, white or 50 percent gray is the neutral color. When 50 percent gray is the neutral color, that means 50 percent gray pixels on the applied layer don’t affect underlying pixels at all, and the farther an applied pixel is from 50 percent gray (that is, the closer it is to black or white), the more it affects the underlying layer.

- How much additional contrast do I want? Part of the reason there are so many blending modes is that quite a few of them are merely variations of other blending modes that produce more or less contrast. For example, Hard Light is a higher-contrast version of Soft Light. Certain blending modes, such as Difference, take contrast to the extreme, inverting (creating the negative of) the original layer color. The blending modes that produce lower contrast tend to compare an applied pixel to an underlying pixel and simply keep one or the other, while the blending modes that produce higher contrast tend to mathematically amplify the differences between the applied and underlying layers.

- What do I want to change? Most blending modes affect any underlying pixel (other than those in the blending mode’s neutral color, if it has one), while some blending modes affect only color or tone.

The blending modes are grouped according to the way they answer those three questions. You’ll find a list of blending modes on the Layers panel, in retouching tools, and in effects. Because this book is about compositing, it focuses on blending modes as they’re used in the Layers panel when you’re combining images.

Let’s take a look at blending mode groups. These overviews should help you recognize when you’d want to use a blending mode to combine images.

In the figure below are the layers used in the examples that follow. Watch what happens to white, black, 50 percent gray, color, and the semitransparent circle in the lower-right corner of the top layer.
Independent Modes. The Normal and Dissolve modes both replace the underlying pixels with the pixels of the applied layer when the layer is at 100 percent opacity. Normal is the default mode. At lower opacities, Normal blends the overlying pixels with the underlying ones according to the layer Opacity value, while Dissolve replaces pixels randomly.

Darken Modes. The neutral color for the Darken modes is white. White pixels on a layer set to a Darken mode leave the underlying pixels unchanged. Nonwhite pixels darken the result by varying amounts, depending on each blending mode’s math and the difference in value between the applied and underlying pixels.
Lighten Modes. The Lighten modes are the inverse of the Darken modes. The neutral color for the Lighten modes is black—black pixels on a layer set to a Lighten mode leave the underlying pixels unchanged. Nonblack pixels darken the result by varying amounts, depending on each blending mode’s math and the difference in value between the applied and underlying pixels.
Contrast Modes. These modes combine corresponding Darken and Lighten modes. The neutral color for the Contrast modes is 50 percent gray—50 percent gray pixels on a layer set to a Contrast mode leave the underlying pixels unchanged. Lighter pixels lighten the result and darker pixels darken the result; the amount depends on the blending mode and the value difference between the applied and underlying pixels.
The odd man out is the Hard Mix blend, which has no neutral color but doesn’t fit anywhere else either. It reduces the image to eight colors—red, cyan, green, magenta, blue, yellow, white, and black—based on the mix of the underlying and blend colors, with a strength related to 50 percent gray.

**Comparative Modes.** The neutral color for Difference, Exclusion, and Subtract is black, and for Divide it’s white. Difference and Exclusion look at each channel and subtract the underlying color from the overlying color or the overlying color from the underlying color, whichever returns a result with higher brightness, and blending with white inverts the underlying color values. Subtract always subtracts the overlying color from the underlying color, while Divide always divides the overlying color from the underlying color.
**HSL Modes.** Blending modes in other groups generally operate on overall tone and color values. The members of the HSL group work with hue, saturation, and luminosity (HSL) instead.

- **Hue.** This blending mode creates a result color with the brightness and saturation of the underlying color and the hue of the overlying color.

- **Saturation.** This mode creates a result color with the brightness and hue of the underlying color and the saturation of the overlying color.

- **Color.** This mode creates a result color with the luminosity of the underlying color and the hue and saturation of the overlying color.

- **Luminosity.** This is the inverse of the Color blending mode. It creates a result color with the hue and saturation of the underlying color and the luminosity of the overlying color.
While this book focuses on the compositing uses for blending modes, that’s not all they’re good for. You’ll also find them used as part of advanced correction and sharpening techniques.

**Selecting Areas to Make Them Transparent**

When you want to make specific areas transparent and it isn’t possible by adjusting Opacity, applying a blending mode, or adjusting layer blending options, you’ll need to manually remove the background of the frontmost image, usually toward the goal of creating a mask. An essential skill for manual background removal is selecting areas. For example, you might want to select the image of a person so that you can composite them with another image.

It would be easy to think that the range of selection tools you have in Photoshop consists of the selection tools you see in the Tools panel. In fact, those selection tools are just the beginning. While many traditional techniques relied on the manual selection tools that have been present in Photoshop for many years, recent versions of Photoshop include many other ways to select areas that are actually much more efficient and easier to use, such as tools that intelligently detect edges and skin tones. Let’s take a look.

**Basic Concepts**

You’ll work with selections more easily and have more flexibility if you keep a few key concepts in mind:

- Selections, channels, and masks are actually all the same thing in different forms, and you can convert one to another easily.

- A channel is a saved selection and looks like a grayscale image in which the black parts are fully deselected (masked out), the white parts are fully selected, and the gray parts indicate partially selected pixels.

- A layer mask is a selection or channel applied to a layer so that the black areas of the mask fully hide the layer and the white areas of the mask are transparent (they show the layer’s pixels). If an area in a layer mask (or channel) is 25 percent gray, that area is 75 percent visible. Remember: “Black conceals, white reveals,” and the lighter the gray, the more selected or visible the area.

- Smooth edge transitions between selected (white) and unselected (black) areas are incredibly important for compositing images, painting, correcting areas within an image—in fact, just about everything you’d want to do in Photoshop.

With all that in mind, and given the wide range of selection options available in Photoshop, what’s important to understand next is how to choose the selection strategy for the compositing situation in front of you.
Selection Strategies

The key to using selection tools is knowing what each of them is good for. The whole point of selection is to separate the areas you want to change from the areas you don’t want to change, and being aware of that goal gives you a head start in choosing the right selection method. It helps if the area you want to select is visually distinct in some way, because Photoshop has ways of selecting areas based on visual differences such as tone, color, or intelligent edge detection.

Selecting Manually. Manual selection tools, including the marquee and lasso tools, date back at least as far as Apple MacPaint on the original 1984 Mac. These classic tools are simple and effective. However, they are one hundred percent manual, so making complex selections is difficult and requires a steady hand. The Pen tool also falls into this category because you can draw a path and convert it to a selection. The advantage of the Pen tool is that paths can be much easier to edit than floating marquee selections; for this reason, storing selections as paths in the Paths panel is a useful alternative to storing selections in the Channels panel.

To cut down on manual labor, start with one of the following methods to rough out an initial selection, and then carve out details with a manual tool.

Selecting by Edge Detection. The most advanced Photoshop selection tools use intelligent edge detection. They don’t find an edge using contrast alone, they’re programmed to try to find edges based on content. The Magnetic Lasso is like a Lasso tool that follows a detailed edge based on your general dragging direction. The Quick Selection tool is more effective because it’s often capable of following complicated edges that include multiple tones and colors; because it works more like the Magic Wand (selecting areas instead of edges) it’s generally much faster than the Magnetic Lasso tool.

The bottom line: Don’t just randomly reach for a selection tool. Think about the ways in which the selection you want can be isolated, and then go for the tools and techniques that will isolate it that way for you.

Selecting by Color and Tone. If the area you want to select is already plainly visible, it’s worth using a tool that will just pick out that area for you. The Magic Wand tool is the traditional way to do this; click it on a pixel and it selects areas with similar tone or color values, such as a blue sky. If you want to select so many areas that using the Magic Wand would be tedious, the Select > Color Range command works similarly but using a dialog. Image > Adjustments > Selective Color also selects color ranges, but it’s specifically tuned for tuning the color of CMYK images.

Another way to select by color and tone is to look through each channel of an image. Sometimes an area that isn’t distinct in the composite channel stands out in one of the image channels, or in a combination of multiple channels. You’ll see examples of this in “Alpha Channels” later in this book.

Now you’re ready to explore those selection strategies in more detail.

Selecting Areas Manually

If the shape of the area you want to select is so simple that you can quickly draw it, reach for one of the marquee or lasso tools (except the Magnetic Lasso). Use
these tools by clicking and dragging. The Polygonal Lasso tool is a bit different; click to set each straight-line segment it creates. The marquee tools select an enclosed area from the start. With the lasso tools, the area you draw automatically closes when you finish drawing. To finish drawing with the Lasso tool, release the mouse; with the Polygonal Lasso tool, double-click when you’re done. Figure 23 shows some examples of these techniques, and Table 1 is a quick reference for manual selection tool techniques.

The Single Row Marquee and Single Column Marquee tools select a single row of pixels and don’t work quite like the others. They always extend across the width or height of the image. They’re useful for things like selecting individual scan lines in an interlaced television image, cleaning up screen captures, or painting a precise line for graphic design.
Figure 23 Manual selection tools

The last manual selection technique is to use the Pen tool and then convert the resulting path into a selection. But that technique is sufficiently different and advanced that it isn’t covered in this book.

**Table 1: Manual selection tool techniques**

<table>
<thead>
<tr>
<th>To do this</th>
<th>. . . do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw a square selection</td>
<td>Shift-drag the Rectangular Marquee tool</td>
</tr>
<tr>
<td>Draw a circular selection</td>
<td>Shift-drag the Elliptical Marquee tool</td>
</tr>
</tbody>
</table>
Draw from the center Option/Alt-drag the Rectangular Marquee or Elliptical Marquee tool

Draw both straight and freeform segments with the Lasso or Polygonal Lasso tool and clicking creates straight segments. As long as you hold down Option (Mac) or Alt (Windows), dragging creates freeform segments.

Draw straight segments: Shift-click the Polygonal Lasso tool at 45-degree increments.

Close a Polygonal Lasso tool selection: Move mouse to start of selection, click when close icon appears; or double-click anywhere.

Cancel the selection you’re drawing: Press Esc.

Tip: To select an area of a specific size, choose Fixed Size from the Style pop-up menu in the Options bar, and then, after typing a value, enter the units you want (“in” for inches, “px” for pixels, and so on). Then press Return or Enter.

Selecting With Edge Detection Tools

If the area you want to select is recognizable as a distinct shape, it’s worth trying the edge detection tools. They try to identify an edge using methods such as looking for contrast in all of an image’s channels.

Magnetic Lasso

Where edges are distinct, you may be able to draw selections faster with the Magnetic Lasso tool than with the Lasso tool that it’s grouped with in the Tools panel. The Magnetic Lasso can seem like magic, or it can seem like a complete waste of time; it all depends on three things: the image, your technique, and your attitude. Use this tool only when you’re selecting something in your image that has a distinct edge. In fact, the more distinct the better, because the program is really following the contrast between pixels. The lower the contrast, the more the tool gets confused and loses the path.

To use the Magnetic Lasso tool, click along the edge of the object you’re trying to select, then move the mouse along the edge of the selection. You don’t have to click or hold down the mouse button except in specific places where the tool isn’t following the edge you want; in those cases click to place points manually, or drag to show the tool where to go. As you move the mouse, Photoshop snaps the selection to the object’s edge. When you’re done, click the first point in the selection again (or triple-click to close the path with a final straight line). Table 2 is a quick reference for Magnetic Lasso tool techniques.
Figure 24 Edge detection and Quick Selection tools

**Table 2: Magnetic Lasso tool techniques**

<table>
<thead>
<tr>
<th>To do this</th>
<th>. . . do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Let tool find edges</td>
<td>Move mouse with mouse button released</td>
</tr>
<tr>
<td>Show tool where edges</td>
<td>Drag the tool along an edge</td>
</tr>
<tr>
<td>Add an anchor point</td>
<td>Click the tool</td>
</tr>
<tr>
<td>Remove last anchor point</td>
<td>Release mouse button and press Delete</td>
</tr>
<tr>
<td>Draw straight segment</td>
<td>Option/Alt-click beginning and end of segment</td>
</tr>
</tbody>
</table>
| Adjust lasso width      | Press [ to decrease or ] to increase, press Shift-[
| Commit to the selection | or Shift-] to set minimum or maximum width          |
| Cancel the selection    | Move mouse to start of selection, click when close icon appears; or double-click anywhere |

The Magnetic Lasso tool has some key settings on the Options bar that can significantly influence how well it works for you.

**Vary the Lasso Width as You Go.** The Lasso Width option in the Options bar determines how close to an edge the Magnetic Lasso tool must be to select it. In some respects it determines how sloppy you can be while dragging the tool, but it becomes very important when selecting within tight spots, such as the middle of a V shape. In general, use a large width for smooth areas and a small width for more detailed areas.

Figure 25 The Options bar for the Magnetic Lasso tool
Fortunately, you can increase or decrease this setting while you move the mouse by using the lasso width adjustment shortcuts in Table 2. If you use a pressure-sensitive tablet, select the Stylus Pressure button on the Options bar; the pressure then relates directly to the Lasso Width.

**Tuning Frequency and Contrast.** These settings (on the Options bar) control how often Photoshop drops an anchor point and how much contrast between pixels it’s looking for along the edge. In theory, a more detailed edge requires more anchor points (a higher frequency setting), and selecting an object in a low-contrast image requires a lower contrast threshold. To be honest, I’m much more likely to switch to a different selection tool or technique before fiddling with these settings.

Don’t work too hard to get a perfect selection with the Magnetic Lasso tool; it isn’t designed to make a perfect selection. It’s designed to create a great starting point that you can edit with other tools.

*Tip* To see the actual size of the Lasso Width and other brush and tool sizes, open the Cursors pane of the Preferences dialog and set Other Cursors to Precise.

### Quick Selection

If you’re more comfortable painting a selection area than with drawing an outline around a selection area, you may want to try the Quick Selection tool. You drag this tool as though you were painting a mask, but instead of getting painted bits back, you get a selection outline similar to a lasso selection. In other words, the Quick Selection tool lets you paint a selection (as if you were working with masks or channels) but see a marquee outline (as if you were dragging a lasso or marquee tool). Another way to look at this tool is that it lets you select while painting, saving you the step of converting a mask or channel into a selection.

Use the Quick Selection tool as you would a brush. Drag it through the area you want to select (see Figure 27-29). Any additional areas you drag over with the Quick Selection tool are automatically added to the existing selection—no need to hold Shift to do that. For this reason alone, Magic Wand fans may want give the Quick Selection tool a try.

It’s important to realize that the Quick Selection tool remembers which colors you’ve included and excluded until you switch tools or switch to Quick Mask mode. For this reason, if you drag any part of the brush over a color you don’t intend to select, press Command-Z (Mac) or Ctrl-Z (Windows) to immediately undo, so that the tool doesn’t start thinking those are examples of areas to include. If you don’t do this, large unwanted areas may be added to the selection, which will make the tool much less effective.

To remove an area selectively, Option-drag (Mac) or Alt-drag (Windows) the tool. After you make your initial drag-selection, your second step should be to Option-drag/Alt-drag color outside your intended selection area to teach the tool about areas that should not be included in the selection. This marks those colors off limits, so that as you continue using the Quick Selection tool on the current image it can be much smarter about which areas it considers to be inside and outside.
Size and Pressure. If the tool consistently selects too much area, go to the Options bar and make the brush harder and its size smaller. If you’re using a pressure-sensitive stylus, apply less pressure for a smaller brush tip, or just turn off Pen Pressure in the Brush pop-up menu and use a small brush size.

Auto-Enhance. In the Options bar, the Auto-Enhance option tries to guess at making a better selection. If you think it’s guessing wrong, turn off Auto-Enhance and fine-tune the edge yourself by clicking Refine Edge. You’ll see the Refine Edge dialog later in this book.

Although the Quick Selection tool has gotten a lot of press as a miraculous selection tool, it’s really just another weapon in your selection arsenal. As with the Magnetic Lasso, the effectiveness of the Quick Selection tool depends in large part on the amount of contrast along the edges of the area you want to isolate. There are still many situations in which another selection method may be faster or easier.

In this example, I want to select a car and its shadow, but the similar colors inside and outside my desired selection confuse most color-based selection tools. With the Quick Selection tool, I can indicate where my desired edges really are.

First I try the Magic Wand tool, but one click selects too many similar colors all over the image (Figure 26). The car color is too close to the pavement color, and the Magic Wand can’t tell the difference between the car’s shadow and all of the other shadows.

Figure 26

I do better by dragging the Quick Selection tool, which easily includes the colors of the red taillight and orange turn lamps in the selection, yet without including the unwanted areas outside the car and its shadow.
Figure 27
I accidentally overshoot the car outline with the brush edge, so the tool picks up some unwanted background.

Figure 28
Option-dragging (Mac) or Alt-dragging (Windows) the Quick Selection tool over unwanted areas excludes them.
Selecting by Tone or Color

The selection tools you’ve seen so far isolate a selection spatially (in terms of space) – either you’re drawing an edge or a Photoshop tool is looking for an edge. But there’s more than one way to look at an image. When the selection you want is easy to isolate by tone or color value, you can use this next set of Photoshop selection tools and tricks.

An important feature of the tone and color selection tools is the idea of tolerance – how similar a tone or color value should be to the value you’ve clicked before it’s considered part of a selection. For example, a blue sky is normally many shades of blue, so if you want to select it by color you’d typically set the Tolerance range wide enough to include all of the sky’s blues, without admitting nearby colors that aren’t part of the sky.

**Magic Wand**

When you click an image with the Magic Wand (dragging has no effect), Photoshop selects every neighboring pixel with the same or similar gray level or color. Neighboring means that the pixels must be touching on at least one side. If you want to select all the similar-toned pixels in the image, whether they’re touching or not, turn off the Contiguous check box in the Options bar before clicking.

The Tolerance value on the Options bar refers to the number of gray levels from the sample point’s gray level. If you click a pixel with a gray level of 120 and your Tolerance is set to 10, you get any and all neighboring pixels that have values between 110 and 130.

In Figure 30, the consistent window color is mostly easy for the Magic Wand, but a small corner is not selected.
In Figure 31, increasing the Tolerance to 100 includes the blue window but extends into the green clock.

In RGB and CMYK images, the Tolerance value is applied to the value in every channel value, not just the gray level. For instance, let’s say your Tolerance is set to 10 and you click a pixel with a value of 60R 100G 200B. Photoshop selects all neighboring pixels that have red values from 50 to 70, green values from 90 to 110, and blue values from 190 to 210. All three conditions must be met, or the pixel isn’t included in the selection (see the next section, “Grow and Similar”).

The Magic Wand will probably be used less frequently now that Photo-shop has the Quick Selection tool. This is no doubt because the Magic Wand involves a lot of careful trial-and-error clicking, which may be why some have dubbed this tool the Tragic Wand. The following techniques can increase your chances of success:

- Try Selecting from a Channel. It’s often difficult to predict how the Magic Wand tool is going to work in a color image. It’s often easier to make selections using a single channel of the image. The Magic Wand is more intuitive on the grayscale image in a channel, and when you switch back to the composite channel, the selection marquee is still there.

- Sample Small, Sample Often. The Magic Wand tool can be frustrating when it doesn’t select everything you want it to. When this happens, novice users often set the Tolerance value higher and try again. Instead, try keeping the Tolerance low (between 12 and 32) and Shift-click to add more parts, or Option-click (Mac) or Alt-click (Windows) to take parts away.

- Sample Points in the Magic Wand. When you select a pixel with the Magic Wand, you may not get the pixel value you expect. It all depends on the Sample Size pop-up menu on the Options bar (when you have the Eyedropper tool selected). If you select 3 by 3 Average or 5 by 5 Average in that pop-up menu, Photoshop averages the pixels around the one you click.
with the Magic Wand. On the other hand, if you select Point Sample, Photoshop uses exactly the one you click.

- **Select in Reverse.** Sometimes it’s easier to first select a large area using a marquee or lasso tool, then subtract the areas you want selected by Option-clicking (Mac OS X) or Alt-clicking (Windows) unwanted areas.

**Tip** If reaching for the Magic Wand tool is a long-established habit for you, consider reaching for the Quick Selection tool as your first choice instead; in many cases using the Quick Selection tool gets the job done much faster and easier than the Magic Wand tool.

**Grow and Similar**

The Select > Grow command can be useful when you have an active selection and you wish it was extended just a bit in terms of tone or color. Grow adds to an active selection according to the following criteria:

1. It finds the highest and lowest gray values of every channel of every pixel selected—the highest red, green, and blue, and the lowest red, green, and blue of the bunch of already-selected pixels (or the highest cyan, magenta, yellow, and black, and so on).

2. It adds the Tolerance value to the highest values and subtracts it from the lowest values in each channel. Therefore, the highest values get a little higher and the lowest values get a little lower (of course, it never goes above 255 or below 0).

3. Finally, Photoshop selects every adjacent pixel that falls between all those values.

In other words, Photoshop spreads the selection in all directions, but only in similar colors. It doesn’t always work the way you want, however. For instance, if you select a pure red area (RGB values 255, 0, 0) and a pure green area (RGB values 0, 255, 0), then choose Grow, Photoshop selects every adjacent pixel that has any red or green in it as long as the blue channel is not outside the Tolerance range. That means it’ll select dark browns, lime greens, oranges, and so on—even if you set a very small tolerance level.

The Similar Command. The Grow command selects only contiguous areas of your image. To select similar pixels from throughout the entire image, choose Select > Similar.

In the following example, Figure 32 shows the original selection made with the Magic Wand tool.

![Figure 32](image)

Choosing the Grow command selects more of the same color, contiguously.
Choosing the Similar command does the same thing, but includes other non-contiguous areas that have the same color.

Figure 33

Tip You may find Grow easier to control if you use it within a single channel.

Figure 34

Color Range

To create a selection based on color, choose Choosing Select > Color Range. You can preview which pixels will be selected, and you can partially select far more pixels than the simple anti-aliasing of the Magic Wand tool. This can be incredibly helpful when you’re trying to tease a good selection mask out of the contents of an image. There’s quite a bit going on in the Color Range dialog, so let’s take a look.

Adding and Deleting Colors. When you open Color Range, Photoshop creates a selection based on your foreground color. You can use the eyedroppers in the Color Range dialog to add or delete colors image colors from the selection or, better yet, hold down the Shift key to get the Add Color to Mask eyedropper, or Option/Alt to get the Remove Color from Mask eyedropper. You can sample colors from any other open image.

Fuzziness. Color Range uses the Fuzziness value to determine not only whether a pixel should be included but also how selected it should be. It’s similar to an alpha channel, in which a pixel can be any value from 0 to 255 on the scale between black and white; lighter values are more selected. Fuzziness is not the same as the Tolerance field on the Magic Wand Options bar. With Tolerance, the only partially selected pixels occur along the selection border. With Fuzziness, a partially selected pixel can be anywhere in the image because it’s based on color, not area.

Localized Color Clusters. One problem with Color Range is that because the default settings are purely color based, areas you don’t want may be added to the selection only because they’re too similar in color to the areas you do want. Reducing Fuzziness is often not the answer if doing so excludes areas you want. The Localized Color Clusters option largely solves this problem. It does this by adding spatial selection, instead of just selecting by color.
When you turn on Localized Color Clusters, Color Range fully selects the pixels that are closest both in color and location to the spot where you clicked with the eyedropper. Pixels having the same color values are less selected farther from where you clicked, so that unwanted areas of the same color are excluded. If too much or too little is selected, use the Range slider to determine the distance used for the selection.

**Preset Colors.** The fastest way to select colors that are primary in RGB or CMYK, such as all the blues or all the greens, is to choose a color preset from the Select pop-up menu at the top of the Color Range dialog. The greater the difference between the color you choose and the other primaries, the more the pixel is selected. (To get really tweaky for a moment, the percentage the pixel is selected is the percentage difference between the color you choose and the primary color with the next highest value.)

You may find that choosing Highlights, Midtones, or Shadows is more useful than the preset colors. When you choose one of these, Photoshop decides whether to select a pixel (and how much) based on its luminance value in Lab mode. Selecting Highlights, Midtones, and Shadows tends to be most useful when selecting a subset of a color that’s already selected.

**Skin Tones and Detect Faces.** In Photoshop CS6, Color Range contains a Skin Tones option in the Select pop-up menu. This works best if the photo doesn’t contain other colors that are similar to skin tones. If choosing Skin Tones selects too much, there are a couple of things you can try. When Skin Tones is selected, the Detect Faces option becomes active; selecting that may help leave unwanted areas. For more manual refining, leave Detect Faces off, turn on Localized Color Clusters, keep the Fuzziness and Range values low, and manually add/delete areas from the selection (see “Adding and Deleting Colors” above).

**Selection Preview.** When you select anything other than None (the default) from this menu, Photoshop previews the Color Range selection mask in different ways.

The first choice, Grayscale, shows you what the selection mask would look like if you saved it as a separate channel. The second and third choices, Black Matte and White Matte, are the equivalent of copying the selected pixels and pasting them on a black or white background. This is great for seeing how well you’re capturing edge pixels. The last choice, Quick Mask, is the same thing as clicking OK and immediately switching into Quick Mask mode. Selection Preview can be really helpful in making sure you’re selecting exactly what you want (no more and no less), but on older or slower machines you may find that it slows you down.

In Figure 35, the goal is to select only the green beans, but other green vegetables prevent Fuzziness from isolating only the desired areas.
In Figure 36, I turn on Localized Color Clusters, Option/Alt-click green areas I don’t want, adjust Range and Fuzziness, and Shift-click green areas I do want.
Figure 36

Tips for Using Color Range

- Fuzziness controls the selected color range by color, while Range controls the selected color range by the distance from where you click the sampler.
- Color Range is one of those dialogs that allows you to continue to navigate in the document window while the dialog is open.
- Instead of using the Image and Selection radio buttons, press the Command or Ctrl key (either one works on the Mac). This toggles between the Selection preview and Image preview much faster than by clicking buttons.
- You can change your Quick Mask options settings while the Color Range dialog is open. Hold down the Option key (Mac) or Alt key (Windows) while selecting Quick Mask from the Selection Preview pop-up menu.
Anti-Aliasing and Feathering

You can partially select pixels in Photoshop. How is this possible? Remember that Photoshop internally handles a selection as a grayscale channel, so it’s a simple matter to store a partially selected pixel as a shade of gray in that channel. One of the most common partial selections is along the edges of a selection. The two most common ways of partially selecting the edges are anti-aliasing and feathering.

**Anti-Aliasing.** If you use the Rectangular Marquee tool, the edges of the selection are nice and crisp, which is probably how you want them. Crisp edges around an oval or irregular shape, however, are rarely a desired effect. That’s because of the stair-stepping required to make a diagonal or curved line out of square pixels. What you usually want are partially selected pixels in the notches between the fully selected pixels. This technique is called anti-aliasing.

Every selection in Photoshop is automatically anti-aliased for you, unless you turn this feature off in the selection tool’s Options bar. Unfortunately, you can’t see the anti-aliased nature of the selection unless you’re in Quick Mask mode, because anti-aliased (partially selected) pixels are often less than 50 percent selected. Once you’ve made a selection with Anti-alias turned off in the Options bar, you can’t anti-alias it—though there are ways to fake it, as you’ll see next.

**Feathering.** Anti-aliasing simply smooths out the edges of a selection, adjusting the amounts that the edge pixels are selected in order to appear smooth. But it’s often (too often) the case that you need a larger transition area between what is and isn’t selected. That’s where feathering comes in. Feathering is a way to expand the border around the edges of a selection. The border isn’t just extended out; it’s also extended in.

To understand what feathering does, it’s important to understand the concept of the selection channel discussed earlier. That is, when you make a selection, Photoshop is really seeing the selection as a grayscale channel behind the scenes. The black areas are totally unselected, the white areas are fully selected, and the gray areas are partially selected. When you feather a selection, Photoshop is essentially applying a Gaussian Blur to the grayscale selection channel.

There are several ways to feather a selection:

- Before selecting, specify a Feather amount in the Options bar.
- After selecting, click Refine Edge in the Options bar and adjust the Feather option.
- After selecting, choose Select > Modify > Feather.
- Apply the Gaussian Blur filter to the selection’s Quick Mask.

If you use the Refine Edge dialog, your entire selection is feathered. Sometimes, however, you want to feather only a portion of the selection. Maybe you want a hard edge on one half of the selection and a soft edge on the other. You can do this by switching to Quick Mask mode, selecting what you want feathered with any of the selection tools, and applying a Gaussian Blur to it. When you flip out of Quick Mask mode, the feathering is included in the selection.
Tips for Using Selection Tools

The important thing to remember about the selection tools (and, in fact, about every selection technique in Photoshop) is that you can freely switch among them as you work. Don’t get too hung up on getting one tool to work just the way you want it to; you can always modify the selection using a different technique. Here are more pointers that can help you use the selection tools most efficiently:

Move a Selection Marquee as You Draw It. If you start drawing a new selection with the Lasso tool or a marquee tool and realize the selection is not in position, keep the mouse button held down, hold down the spacebar, drag to reposition the selection, and release the spacebar.

Move a Selection Marquee After You Draw It. As long as you see the animated selection marquee, you can move the marquee without moving pixels, as long as you drag it using the Lasso tool or a marquee tool.

Scroll the Window While Selecting. It’s natural to zoom in close when you’re dragging a selection tool—nothing wrong with that. But unless you have an obscenely large monitor, you won’t be able to see the whole of the object you’re selecting. No problem; the grabber hand works just fine while you’re selecting—just hold down the spacebar and drag the image around. You can also press the + and - (plus and minus) keys to zoom in and out while you make the selection.

Add To and Subtract From Selections. You can add to the current selection by holding down the Shift key as you drag a selection tool outside the current selection area. Conversely, you can subtract from the current selection by holding down the Option key (Mac) or Alt key (Windows). Or if you want the intersection of two selections, hold down the Option/Alt and Shift keys while selecting. If you don’t feel like remembering these keyboard modifiers, you can...
click the Add, Subtract, and Intersect buttons on the far left side of the Options bar instead.

**Inverse Selecting.** One simple but nonobvious way to save time is to select a larger area with the Lasso or a marquee tool and then subtract the parts you don’t want, like sculpting marble.

**Select It Again.** It’s common to charge ahead with edits after selecting an area and later realize you need that last selection back. You can often recall it by pressing Command-Shift-D (Mac) or Ctrl-Shift-D (Windows), the shortcut for Select > Reselect.

**Don’t Forget About the Options Bar.** Each tool has additional settings in the Options bar that may come in handy. The most useful is probably the Refine Edge button, which opens the Refine Edge dialog, which you’ll see later. For the marquee tools, the Style pop-up menu lets you specify a size or aspect ratio for the selection, making it easy to precisely select a rectangular area that you’re trying to isolate.

**Combine Selection Tool Keyboard Shortcuts.** For example, to draw a circle outward from the center using the Elliptical Marquee tool, combine the shortcut for drawing from the center (Option/Alt) with the shortcut for drawing a circle (Shift): Option-Shift-drag (Mac OS X) or Alt-Shift-drag (Windows) the tool.

---

Figure 38 Adding to and subtracting from selections

Figure 39 The Options bar for the Rectangular Marquee tool, showing the Style pop-up menu
There’s a fair chance that Photoshop will forget the last selection after you’ve made a few other types of edits, so if you have the slightest suspicion that you might need a selection again, choose Select > Save Selection to store it in the Channels panel.

The Modify Submenu

When you think of the most important part of a selection, what comes to mind? If you answer, “what’s selected,” you’re wrong. No matter what you have selected in your image, the most important part of the selection is the boundary or edge. This is where the rubber hits the road. No matter what you do with the selection—whether you copy and paste it, paint within it, or whatever—the quality of your edge determines how effective your effect will be.

When making a precise selection, you often need to make subtle adjustments to the selection boundaries. The four menu items on the Modify submenu under the Select menu—Border, Smooth, Expand, and Contract—focus entirely on this task.

Border. There’s a faster way to get a doughnut than driving down to the local Krispy Kreme. Draw a circle using the Elliptical Marquee tool, then choose Select > Modify > Border. You can even specify how thick you want your doughnut (in pixels, of course). Border transforms the single line (the circle) into two lines (see Figure X).
The problem with Border is that it creates only soft-edged borders. If you draw a square and give it a border, you get a soft-edged shape that looks more like an octagon than a square. To get a harder edge out of the Border command, click Refine Edge on the Options bar and turn up the Contrast.

Smooth. The problem with making selections with the Lasso tool is that you often get very jagged selection lines; the corners are too sharp, the curves are too bumpy. You can smooth these out by choosing Select > Modify > Smooth. Like most selection operations in Photoshop, this actually runs a convolution filter over the selection mask—in this case, the Median filter. That is, selecting Smooth is exactly the same thing as switching to Quick Mask mode and choosing the Median filter.

Smooth has little or no effect on straight lines or smooth curves, but it has a drastic effect on corners and jagged lines. Smooth looks at each pixel in your selection, then looks at the pixels surrounding it (the number of pixels it looks at depends on the Radius value you choose in the Smooth dialog). If more than half the pixels around it are selected, the pixel remains selected. If fewer than half are selected, the pixel is deselected.

If you enter a small Radius value, only corner tips and other sharp edges are rounded out. Larger values make sweeping changes. In most cases you’ll
probably use a value lower than 5 or 6, but it depends entirely on what you’re doing (and how smooth your hand is!).

**Expand and Contract.** The Expand and Contract commands let you enlarge or reduce the size of the selection. They’re similar to the Shift Edge option in the Refine Edge dialog.

Once again, these modifiers simply apply filters to the black-and-white mask equivalent of your selection. Choosing Expand is the same as applying the Maximum filter to the mask; choosing Contract is the same as applying the Minimum filter. While these older selection modifiers are useful, they aren’t very precise because you can specify the radius only in 1-pixel increments. For a lot more control, use the Refine Edge dialog instead.

If the difference isn’t clear between the Expand and Contract commands and the Grow and Similar commands discussed earlier, think of it this way: Expand and Contract adjust a selection spatially, while the Grow and Similar commands adjust a selection by tone and color.

**Tip** If you enter 5 as the Radius value in the Expand or Contract dialog (or in the Maximum or Minimum dialog), it’s exactly the same as running the filter or selection modifier five times. The Radius value here is more of an iteration value: How many times do you want to apply the filter at a 1-pixel radius?

---

**Feathered and Semitransparent Selections**

There’s reality, and there’s Photoshop. In real life, light never forms solid edges; there’s always some transparency where light meets shadow. The ability to create feathered (soft-edged) selections and masks is key to making localized corrections blend into the image in a way that seems natural—and it makes Photoshop selections a lot more useful than hard-edged, solid, real-world masking tape.

Figure 42 shows a soft-edged selection. I created it by clicking the Refine Edge button in the Options bar while the selection was active, and then applying a 50-pixel Feather. Behind the scenes, rather than creating a simple bi-level channel, the feathered selection creates a channel that contains intermediate grays as well as black and white, which you can see if you click the rightmost button at the bottom of the Refine Edge dialog. The gray pixels are partially selected—lighter grays are more selected than darker ones—so any effect applied through the selection affects the fully selected pixels completely and the partially selected pixels in direct proportion to how selected they are, and it doesn’t affect the unselected pixels at all.

---

Figure 41 The Refine Edge button on the Options bar is available when a selection and a selection tool are active.
In the Refine Edge dialog, the View Mode can display the selection in different ways; in Figure 42 the Marching Ants option previews a selection as a simple marquee outline. In the Output To menu, choosing Layer Mask is the most flexible, least destructive option.
In Figure 43, On White is selected in the View menu. This is a good way to preview how the current edge settings will look on paper. Here, On White shows the effect of setting the Feathering option to 50 pixels in Figure 42.

**Floating Selections**

It’s time to take a short detour off the road of making selections and delve into the world of what happens when you select pixels and then move them: They turn into a floating selection, a temporary layer just above the current layer. As soon as you deselect the floating selection, it merges down into the current layer, replacing whatever pixels were below it. Although these floating selections act like layers, they don’t show up in the Layers panel and will merge down if you lose the selection.

You can manipulate a floating selection as you do a layer. You can change its blending mode by choosing Edit > Fade. (Unintuitive, but true.) However, as soon as you try to paint on it, or run a filter, or do almost anything else interesting to the floating selection, Photoshop deselects it and drops it back
down to the layer below it. That’s one reason I’d rather just convert the selection into a real layer before messing with it. To do this, right after making a selection of pixels that you’re about to move, press Command-J (Mac OS X) or Ctrl-J (Windows) — that’s the shortcut for Layer > New > Layer from Selection. After moving the new layer, drop it back into the underlying layer by pressing Command-E (Mac OS X) or Ctrl-E (Windows), the shortcut for Layer > Merge Layers (unless you want to preserve it as its own layer).

Figure 44 Floating selections and layers

**Editing Selections**

There are lots of times when a selection isn’t perfect the first time you create it. For this reason, when you composite images you may spend quite a bit of time editing selections. Fortunately, Photoshop provides many ways to tweak a selection.
Saving, Reusing, and Converting Selections

Another huge advantage of digital masking tape is that, unlike its real-world equivalent, you can easily copy it, move it, tweak it, or reuse it a year later. When you save a selection as a channel, you can recall it easily and either reuse it as a selection or apply it as a mask to a layer. Basically, the difference between a mask and a channel is that a mask currently affects its layer, while a channel is stored in the Channels panel without affecting the image in any visible way until you convert it to a selection or mask.

The flexibility with which you can turn a selection into a channel or mask is one of the major reasons for getting into the habit of always saving any selection that’s even slightly complex. Loading a saved selection from a channel is certainly much faster than having to rebuild it all over again.

**Saving Selections as Channels.** To convert a selection to a channel, click the Save Selection as Channel button at the bottom of the Channels panel. When a selection is converted to a channel, white represents selected pixels are black represents unselected pixels. The selection appears as a new channel in the Channels panel. That’s a shortcut for choosing the Select > Save Selection command and filling out the dialog, although the dialog gives you more options.

**Converting Channels to Selections.** To turn a channel into a selection, Command-click (Mac) or Ctrl-click (Windows) the channel in the Channels panel. That’s a shortcut for selecting the channel and then clicking the Load
Channel as Selection button in the Channels panel, or choosing Select > Load Selection. This converts the white and black pixels in the channel to selected and unselected pixels, respectively.

**Converting Selections to Masks.** Photoshop always adds a layer mask when you create an adjustment layer. Even better, if you have a selection active when you add an adjustment layer, that selection automatically becomes the layer mask for that adjustment layer.

For other types of layers, select a layer and click the Add Layer Mask button at the bottom of the Layers panel. The long way to do this is to choose a command from the Layer > Layer Mask submenu (the menu also provides more options).

![Figure 46Converting a selection to a layer mask](image)

**Moving Selections Between Documents**

It’s easy to move selections between documents. You have more options if both documents have exactly the same pixel dimensions.

**Drag and Drop.** You can use one of the selection tools to drag an active selection to another document. Normally the selection drops wherever you release the mouse; to drop the selection in exactly the same position in the destination
document, hold down the Shift key just after you start dragging the selection from the original document. If the images don’t have the same pixel dimensions, the Shift key drops the selection at the center of the destination document.

You can also drag an entire channel from the Channels panel and drop it onto another open document of the same pixel dimensions.

**Save Selection, Load Selection, and Duplicate Channel.** If you choose Save > Save Selection or Duplicate Channel from the Channels panel menu, you’ll find a Document pop-up menu that let you save a selection to the Channels panel of another document. If you choose Select > Load Selection, the Document pop-up menu in that resulting dialog lets you import a channel from another document. In all three cases, you’ll see other documents in that pop-up menu only if they’re currently also open and they have the same pixel dimensions as the document that was in the foreground when you chose the command.

## Working With Selections, Masks, and Channels

If you’ve ever carefully painted around a window in your home, you’ve probably used masking tape to mask out the areas you didn’t want to paint. If you apply the masking tape to the window, you can paint right over it, knowing that the window remains untouched. Selections, masks, and channels are like electronic masking tape.

Deep down, selections, masks, and channels are different forms of the same thing. No matter what kind of selection you make—whether you drag a rectangular marquee, draw a path with the Lasso, or use the Quick Selection tool to select a colored area—Photoshop sees the selection as a grayscale channel. In this selection channel, the areas that you selected (the parts with no masking tape over them) are white, and the unselected areas (the parts with masking tape over them) are black. This has led to a popular saying: Black conceals, white reveals. Photoshop offers three ways to interact with selection channel information:

- You can use the selection tools—Marquee, Lasso, Magic Wand, Color Range, and so on—to create a selection.
- When you save a selection, Photoshop saves it as an alpha channel—a grayscale channel stored alongside the color channels. Alpha channel is a fancy term for a simple concept: It’s just a saved selection.
- To apply selection information nondestructively to a layer (meaning that you can change or remove the selection), you use it as a layer mask—in other words, you’re attaching the masking tape to just that layer.

As you saw in Figure 45 and 46, a rectangular marquee provides a good example of how Photoshop thinks of a selection: Each pixel is either selected or not, and the channel that results when the selection is saved contains only black and white pixels. It works like real masking tape—the black pixels in the selection are the masking tape, protecting whatever’s underneath, and the white pixels represent the area without masking tape, letting the paint (that is, the adjustment) pass through.
You can translate between selections and layer masks as easily as you can translate between selections and channels, since like a channel, a layer mask is simply a grayscale image. Many channel concepts and techniques carry over to layer masks, such as making and refining a selection and filling it with black or white.

You’ll find out how to bounce the information back and forth among selections, channels, and masks as you progress through this section.

**Converting a Selection to a Mask Using Refine Edge**

Certain features are conceived because someone sees an opportunity to streamline a multistep manual chore. The Refine Edge dialog is this kind of new feature. Until Photoshop CS4, if you applied the Select > Feather command, the only way to actually see the size of the feather was to view the selection as a Quick Mask or channel. And you already know by now that you can tweak a selection edge by converting the selection to a Quick Mask or a channel and then using image-editing commands (such as Levels and Gaussian Blur) to alter contrast along the edges of the selection channel. Of course, that meant you had to know which exact series of operations would get you the result you wanted.

The Refine Edge dialog relieves you of much of that brainwork. Now you can simply tell Refine Edge how you want to tune the selection edge, you get to preview and adjust it, and then it’s done. Behind the scenes, Refine Edge works with a selection as a channel so that you don’t have to go through tricky channel operations yourself. You can even use Refine Edge on a mask or channel. In Photoshop CS5, Adobe endowed Refine Edge with new super powers that make it easy to create selections from difficult edges, such as fine hair. In fact, I’ll use fine hair as an example.
Before you use Refine Edge, you’ll need a selection. Because my example involves a human figure with complex edges such as clothing and hair, I decide that the amazing Quick Selection tool is the fastest way to arrive at a fast yet reasonably accurate selection. As I described earlier, I drag the Quick Selection tool over the areas of the figure I want to show, and Option/Alt-drag the tool over the areas I want to hide, varying the brush size as needed. Once I have an edge I’m happy with, with the selection still active I click the Refine Edge button in the Options bar to open the Refine Edge dialog.
Figure 49: My initial selection of the spinning girl doesn’t include every detail of the hair, but I can add to the selection in Refine Edge

**Using Radius and Smart Radius**

Starting from the initial selection edge you create, the Radius value tells Refine Edge how far out it should think about improving the selection edge. Radius is more sophisticated than a standard feather or edge blur because it protects existing hues and creates a less artificial-looking transition. A higher Radius value can help when the exact edge is hard to follow, such as the edge of a soft shadow or hair. For my example I found that I needed to start with at least a 15-pixel Radius for Refine Edge to properly surround the wide edge created by the flying hair, and I settled on 50 pixels. If I set Radius too low, Refine Edge ignores too many of the hairs that are outside my initial selection; if I set Radius too high, the half of the Radius that extends into the subject may make interior areas of the subject transparent, which is wrong. When working out the appropriate Radius value, it helps to set the View Mode to Radius (press J) so that you can see the exact width and position of the zone where Refine Edge will be doing its magic, and it’s easier to see when you’ve gone too far. Use a value somewhere in the middle.

Figure 50: Extreme Radius values, previewed with the View Mode set to Show Radius

In the left image in Figure 50, the Radius value is too low. At 5 pixels, Refine Edge won’t help much because too much hair is not inside the Radius. In the
right image, the Radius value is too high; at 100 pixels it intrudes so far into the subject that areas such as those on the arm are becoming transparent.

The problem with setting a single Radius value is that many subjects have both soft and hard edges. In my example, the subject has hard edges along the skin and clothes, but the flying hair has fine details and soft edges. To succeed with these mixed edges, Adobe added the Smart Radius option. When you turn on Smart Radius, it varies the Radius value and its position along the selection edge depending on the hardness of the subject’s edge. In my example, turning on Smart Radius increases the Radius around the hair where the subject’s edge is softer. Along hard edges, Smart Radius may also slightly shift the Radius away from the subject so that edge refinements are concentrated a bit more on the transition area, instead of being perfectly centered over the outside and inside of the subject.

![Figure 51Smart Radius](image)

In the left image in Figure 51, I settle on a Radius value of 50 pixels. The correct value varies depending on the pixel dimensions of a particular image. In the image on the right, turning on Smart Radius varies the size and position of the Radius value along hard and soft edges.

**Tip** For a traditional feather, leave Radius at 0 and use the Feather slider instead—as long as you understand that Radius can usually do a more intelligent job.

### Using the Radius Refinement Tools

In my Refine Edge example, there are wisps of hair that are pretty far out beyond the current Radius even with Smart Radius on, but if I increase the Radius to get to them, the Radius value will be too large for most of the edge. Fortunately, Refine Edge has two tools that address this problem. The Refine Radius tool lets you extend the Radius anywhere along the edge, and the Erase Refinement tool lets you exclude areas from the Radius.

**Refine Radius.** While my Radius value is a reasonable compromise for both the hard and soft edges, it still cuts off hair ends that should be included. I quickly discovered this by toggling between the On Layers and Reveal Layer view modes, which is easiest to do if you simply alternate between pressing the L key.
and R key individually—you see these keys listed as the shortcuts in the View pop-up menu in the Refine Edge dialog.

Figure 52 Toggling between view modes to see where more hair needs to be brushed in using the radius refinement tools

In the left image in Figure 52, the On Layers view mode shows the current results of the Refine Edge dialog over the underlying layer. In the right image, the Reveal Layer view mode shows just the original subject’s layer, making visible hair details outside the current selection.

To bring out those hair ends, I select the Refine Radius tool (press E) in the Refine Edge dialog and brush along the hairs until I get to the ends (see Figure X). The areas you brush in appear light gray until you release the mouse button; after that Refine Edge calculates the new edge and you can see the results before continuing. While you should use a brush size that’s appropriate to the size of the details you’re trying to include, you don’t need to follow the edge tightly; in fact, a generously wide brush stroke helps bring out finer details and softens the transition. Because the On Layers view mode doesn’t show the details you’re trying to reveal, you might find that you can work more clearly with the Refine Radius tool in another view mode such as Overlay or Reveal Layer.

Figure 53 Using the Refine Radius tool to extend the Radius to the hair tips
In Figure 53 you first see the original radius; in the middle image I bring out details using the Refine Radius tool, resulting in the additional detail you see in the final image.

**Erase Refinement.** This is the opposite of the Refine Radius tool. You can use the Erase Refinement tool to brush over areas that should not be used to calculate the edge, so that Refine Edge tightens up the edge and reduces transparency in those areas.

*Tip* Change the size of the Refine Radius and Erase Refinement tools the same way you would for any other brush tool: by pressing the `[` or `]` key.

### Adjusting the Edge

Once you’ve got the Radius down, you can use the Adjust Edge options to change the quality of the detected edge.

**Smooth.** The Smooth slider evens out bumps along the selection edge to help compensate for sloppy selections. However, if your edge follows details like hair, a high Smooth value can obliterate them. If you have to set such a high Smooth value that you lose details, you may need to click Cancel and improve the precision of your initial selection.

**Feather.** The Feather slider simply blurs the edge like the traditional Select > Modify > Feather command in Photoshop itself. If you start to lose the edge, you’ve turned it up too far. It’s more useful for soft-edged subjects than hard-edged ones.
**Contrast.** This option determines the sharpness of the transition across the radius you set. A higher value creates a sharper edge. If edges are so sharp that the compositing looks too obvious, you’ve turned it up too far.

**Shift Edge.** If your selection is a little bit inside or outside of the area you wanted to select, use Shift Edge to compensate. Shift Edge can be an easy way to remove a color fringe when the edge is consistent.

![Figure 54](https://via.placeholder.com/150)

Figure 54 The Shift Edge option

In Figure 54, I start with the first image. In the second image I set Shift Edge to -30, which tightens the edge but loses some fine hairs. In the third image I set Shift Edge to +30, which is too much because fringing is visible, especially down by the trees. The best value is somewhere between 0 and +30.

**Decontaminate Colors.** If you still see color fringing around your selection and you can’t get rid of it with the options above without losing detail or the edge, try selecting this option and increasing the Amount slider. As you increase Amount, Refine Edge replaces more of the background fringe color with color from the subject. If patches of the original background still show through, grab the Refine Radius tool and brush them out.
In Figure 55, I start with the first image where a white background fringe is visible over the leaves. In the second image I set Decontaminate Colors to 70%, which replaces the white fringe with the hair color to make it less visible. In the third image I set Decontaminate Colors to 100% but this smears the details, so I should back off and find a better value between 70% and 100%.

**Tip** If you want a soft edge to be harder and the Feather value is zero, increase Contrast. If you want a hard edge to be softer and the Contrast value is zero, increase the Feather value.

**Getting it Done**

After everything looks as good as it’s going to be, but before you click the OK button, be mindful of what’s selected in the Output To pop-up menu. If you want to give yourself an escape route in case you don’t like the results, choose one of the options that creates a layer (or better, an editable layer mask) that you can easily discard without affecting the original layer. Once the Output To option is set, click OK to close the Refine Edge dialog and apply the new selection edge.
As you can see in my example, if you want a truly convincing composite, give your own subject and background more consistent lighting than mine!

Although the Refine Edge dialog has greatly automated the selection of edges, there are still times when you have to build and modify selections by hand, using the traditional Photoshop selection features I covered earlier.

Note if you used the Decontaminate Colors option, you can’t use the Selection or Layer Mask options because those options require changing the colors of at least some image pixels, which means a new layer or document must be created.

Selecting with Channels

Selections, masks, and channels are all the same thing down deep: grayscale images. This is not intuitive, nor is it easy to grasp at first. But once you really understand this point, you’ve taken the first step toward really surfing the Photoshop big waves.

A channel is an independent grayscale image. You can have up to 56 channels in a document—and that includes the three in an RGB image or four in a CMYK image. (Actually, there are two exceptions: Images in Bitmap mode can only contain a single 1-bit channel; second, Photoshop allows one additional channel per layer to accommodate layer masks, which you’ll read about later.)

Color Channels

When a color image is in RGB mode (under the Mode menu), the image is made up of three channels: red, green, and blue. You can make any single color channel visible or invisible, but you can’t delete or add a color channel without first changing the image mode, because the channels are integral to the color mode (you can’t have an RGB image without a red channel).

The first thumbnail in the Channels panel is the composite channel. Actually, this isn’t really a channel at all. Rather, it is the full-color representation of all the individual color channels mixed together. The composite channel gives you a convenient way to select or deselect all the color channels at once, and also lets you view the composite color image, even while you’re editing a single channel.
Viewing and Selecting Channels. The tricky thing about working with channels is figuring out which channel(s) you’re editing and which channel(s) you’re seeing on the screen. They’re not always the same!

The Channels panel looks a lot like the Layers panel, with the same eyeball icons that you can turn on and off to show or hide individual channels. Clicking a thumbnail or channel name displays that channel and makes it active for editing. The shortcuts for selecting multiple channels are the same as they are for layers. When you display more than one channel at a time, the alpha channels automatically switch from their standard black and white to their channel color (you can specify what color each channel uses in Channel Options by double-clicking the channel thumbnail).

Table 3 lists keyboard shortcuts that are useful with channels.

Table 3 Channel shortcuts

<table>
<thead>
<tr>
<th>To do this . . .</th>
<th>. . . do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the composite channel</td>
<td>Press Command-2 (Mac OS X) or Ctrl-2 (Windows)</td>
</tr>
<tr>
<td>View other channels</td>
<td>Press Command/Ctrl-3 through Command/Ctrl-9</td>
</tr>
<tr>
<td>Load a channel as a selection to the above shortcuts</td>
<td>Add the Option (Mac OS X) or Alt (Windows) key</td>
</tr>
</tbody>
</table>

Alpha Channels

People get nervous when they hear the term alpha channel, because they figure that with such an exotic name, it must be complex. Not so. An alpha channel is really just another grayscale channel. The reason it needs its own name is that it isn’t one of the channels that make up the visible image. For example, although a typical RGB image has three channels—red, green, and blue—an RGB image with one alpha channel has four channels in all.
Alpha channels aren’t just another way of storing a selection marquee. They’re also used by various Photoshop features as a way of marking areas you want to alter or protect. For example, the Lens Blur filter can simulate depth of field by using gradients in an alpha channel as a depth map, and the Content-Aware Scale command can use an alpha channel to protect specific areas from being scaled.

**Saving Selections.** I said earlier that you can choose Select > Save Selection to store a selection with an image as an alpha channel (see Figure X). If the Channels panel is visible, it’s faster to click the Save Selection icon in the Channels panel. Or if you want to see the Channel Options dialog first (for instance, to name the channel), Option-click (Mac) or Alt-click (Windows) the icon.

**Loading Selections.** To retrieve a selection you saved, in the Channels panel Command-click (Mac) or Ctrl-click (Windows) on the channel that you want to use as a selection (the shortcut for choosing Select > Load Selection). Even better, press the Command and Option (Mac) or Ctrl and Alt (Windows) keys along with the number key of the channel you want (the numbers are listed along the right side of the Channels panel). For instance, if you want to load channel 6 as a selection on a Mac, press Command-Option-6.
Channels in TIFF Files. If you’re saving channels along with the image you’re working on, and you want to save the file as a TIFF, you might consider turning on Zip compression in the Save as TIFF dialog. An uncompressed TIFF file with additional channels (and layers) can be quite large. Of course, you could save in the native Photoshop format, but a Zip-compressed TIFF is almost always smaller on disk. However, one reason to use PSD format instead of Zip-compressed TIFF is that a Zip-compressed TIFF can take a long time to save.

Adding, Subtracting, and Intersecting Selections. Let’s say you have an image with three elements in it. You’ve spent an hour carefully selecting each of the elements, and you’ve saved each one in its own channel. Now you want to combine the three selections. After you load one channel as a selection, choose Select > Load Selection to add another channel to the current selection, subtract another channel, or find the intersection between the two selections. Even easier, use the key-click combinations in Table 3. Confused? Don’t forget to watch the cursor icons; as you hold down the various key combinations, Photoshop indicates what will happen when you click.

![Figure 59Combining channels](image)

Table 3: Using the Channels panel to combine selections.

<table>
<thead>
<tr>
<th>To get this</th>
<th>. . . press this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add channel to current selection</td>
<td>Command-Shift-click (Mac) Ctrl-Shift-click</td>
</tr>
<tr>
<td>(Windows)</td>
<td></td>
</tr>
</tbody>
</table>
Comparing Layer Transparency and Layer Masks

Layer content can be made transparent using either layer transparency or a layer mask. Here’s the difference: When you create transparency by deleting areas of a layer, the deleted pixels are gone forever. When you create transparency using a layer mask, the mask carries transparency information independently of a layer while leaving the complete original layer intact. For this reason, layer masks are preferred because they’re nondestructive.

Figure 60Comparing layer transparency and layer masks; both achieve the appearance shown in the middle, but with a layer mask as shown on the right, you can easily “un-hide” transparent areas at a later time

You can create layer transparency simply by selecting areas of a non-background layer and pressing Delete, or using any of the tools in the Eraser tool group in the Tools panel. You create transparency in a layer mask by adding one and painting black onto it.

Tip Flattening an image removes all layers, layer transparency, and layer masks, and creates an opaque white background, so avoid flattening unless it’s what you really want or if you’re working on a duplicate of a layered image.

Viewing Masks

If you want to see only the layer mask, Option-click (Mac) or Alt-click (Windows) on the layer mask’s thumbnail in the Layers panel. This is most helpful when touching up areas of the layer mask (it’s sometimes hard to see the details in the mask when a background image is visible), and it’s especially important when pasting into a channel or mask. You can disable (hide) a mask
by Shift-clicking a mask thumbnail in the Layers panel; when you do this a red X appears in the mask thumbnail.

![Layer mask thumbnail](image)

If you want to see the mask as a transparent overlay over the image, press the backslash key (\). If you’re editing an adjustment layer, make sure you only tap the backslash key, since holding down that key displays the state of the image before the current adjustment (a before-and-after comparison).

**Copying Layer Masks.** To copy a layer mask, in the Layers panel Option-drag (Mac) or Alt-drag (Windows) the layer mask thumbnail to the layer where you want to apply the mask.

**Using the Properties Panel for a Mask**

If you spend any significant amount of time working with masks, get to know the Properties panel. When you select a mask in the Layers panel, the Properties panel displays the properties of the mask. Editing masks to get them just right has traditionally involved various power-user techniques. Like the Refine Edge dialog and the Adjustments panel, the mask properties are another example of how related features in Photoshop have been simplified and consolidated from a task-oriented point of view. For example, instead of having to control mask density by using the Output Levels sliders in the Levels dialog, all you have to do now is yank the Density slider in the Properties panel.
Up to this point I’ve been talking about layer masks that are made up of pixels, but the Properties panel also accommodates vector masks made up of paths. When you click the Vector Mask button in the Properties panel, the current layer gets a new vector mask if it doesn’t already have one.

**Pixel Masks.** When you click the Pixel Mask button in the Properties panel, a new pixel mask is added to the current layer, if it doesn’t already have one. Use any painting tool to create black (transparent), white (opaque), and gray (semitransparent) areas in a pixel mask. The Properties panel provides these controls for a pixel mask:

- **Density.** Use this option to change the opacity of the mask so that you can control it independently of the layer opacity. Sure, you were able to do this in Photoshop CS3 and earlier by applying an image adjustment such as Levels to the mask, but repeated adjustments would degrade the mask. The Density slider is better because it’s nondestructive—you can easily dial it back at any time.

- **Feather.** This option controls the softness of the mask edges. This nondestructive option lets you freely adjust edge blur without having to apply a blur filter.

- **Mask Edge.** This button is the same as the Refine Edge feature discussed earlier; it fine-tunes the edge of a selection. Because selections and masks are two forms of the same thing, it’s as helpful to have Refine Edge in the Properties panel as it is to have it in the Options bar for selections.

- **Color Range.** This option is good for creating a mask if you just added one and you need to isolate an area by color. Color Range was discussed earlier in this book.

- **Invert.** This option exchanges the opaque and transparent parts of a mask so that you can choose to paint the masked area with black or white and just swap those colors later. It’s yet another shortcut to the Image > Invert.
command, which you can also get by pressing Command-I (Mac OS X) or Ctrl-I (Windows).

**Vector Masks.** This type of mask is defined by paths you draw and edit using the Pen tool and shape tools that aren’t covered in this book. Areas outside the path are transparent, and areas inside it are opaque. Although a vector path is hard-edged by nature, you can use the Feather slider to apply a nondestructive feathered edge to a vector mask—this was not possible in earlier versions. The only other option for vector masks is Density. To make any other kind of change to a vector mask, you must either edit its path using the Pen tool group or convert its path to a selection or channel so that you can edit it as a selection or as pixels, respectively.

**Editing and Painting in Layer Masks**

When you need to make detailed adjustments to a mask, it’s important to realize that you can edit a mask with any of the brushes or retouching tools in Photoshop. For example, you can paint a grayscale image into a mask to create any kind of mask shape you want.

**Figure:** Some custom masks

Being able to apply most Photoshop editing tools to a mask can help you quickly tune a mask. You can use Photoshop features that adjust image contrast, or make local adjustments with the brush or retouching tools such as Dodge and Burn. Professional retouchers use advanced masking techniques that are built upon these tools and principles.

**Figure 62** Increasing contrast sharpens a mask edge, while applying a blur softens the edge.

Keep in mind that many of the traditionally manual methods of editing masks can now be done more easily and automatically using the Refine Edge dialog. For example, the Contrast slider in Refine Edge adjusts mask edges in a way that’s very similar to the Levels and Blur examples in the figure above.

Here are a few more tips that help you get through your layer mask edits more quickly:

- The Option (Mac) and Alt (Windows) key reverses the selected and unselected areas when you click the Add Layer Mask button in the Layers panel or the Save Selection as Channel or Load Channel as Selection buttons in the Channels panel.

- If you want an adjustment layer to affect a small area, fill its mask with black and paint in the adjustment with white. Press D to set the default mask colors (white foreground and black background). Press Command-Delete (Mac) or Ctrl-Delete (Windows) to fill the layer with the background color (black). You’re ready to brush in the adjustment with white. If needed, press X to switch between foreground and background colors.

- The Add Layer Mask button in the Layers panel and the Layer > Layer Mask > Reveal All command do the same thing.

- By default, a new layer mask is filled with white (the entire layer is opaque). If you Option-click (Mac) or Alt-click (Windows) the Add Layer Mask button in the Layers panel, the layer mask inverts (the layer becomes transparent).
• If a selection exists when you create a layer mask, everything outside the selection becomes transparent (filled with black) in the new mask. The Option/Alt key inverts this behavior too.

• A layer group can have a mask, and that’s handy for creating nested masks. Select the layers, group them by pressing Command-G (Mac) or Ctrl-G (Windows), which is the shortcut for choosing Layer > Group Layers, and then add a mask to that layer group.

Table 4 lists even more helpful shortcuts for viewing and editing layers.

**Table 4 Layer mask shortcuts.**

<table>
<thead>
<tr>
<th>To do this</th>
<th>do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch from layer to layer mask</td>
<td>Command-\ (Mac OS X) or Ctrl-\ (Windows)</td>
</tr>
<tr>
<td>Display layer mask only</td>
<td>Option-click (Mac OS X) or Alt-click layer mask thumbnail</td>
</tr>
<tr>
<td>Switch painting focus back to layer</td>
<td>Press Command-2 (Mac OS X) or Ctrl-2 (Windows) (the composite channel view shortcut)</td>
</tr>
<tr>
<td>Display both a layer and its mask</td>
<td>Option-Shift-click (Mac OS X) or Alt-Shift-click (Windows) layer mask thumbnail, or press \</td>
</tr>
<tr>
<td>Disable layer mask</td>
<td>Shift-click layer mask icon</td>
</tr>
<tr>
<td>Customize mask preview</td>
<td>Double-click layer mask icon</td>
</tr>
</tbody>
</table>

**Getting Rid of the Mask.** As soon as you start editing layer masks, you’re going to find that you want to turn the mask on and off to get before-and-after views of your work. You can make the mask disappear temporarily by choosing Layer > Layer Mask > Disable. Or do it the fast way: Shift-click a layer mask icon.

If you want to delete a mask forever, choose Layer > Layer Mask > Delete (or, faster, drag the Layer Mask icon to the Trash icon). Photoshop gives you a last chance to apply the mask to the layer. Note that if you do apply the mask, the masked (hidden) portions of the layer are actually deleted.

**Using a Layer As a Mask**

A clipping mask lets a layer act as a mask (see Figure X). In the Layers panel, select one or more layers directly above the layer you want to use as a mask, and press Command-Option-G (Mac) or Ctrl-Alt-G (Windows), the keyboard shortcut for choosing Layer > Create Clipping Mask. You can also Option-click (Mac) or Alt-click (Windows) the dividing line between the base layer and the higher layers you want it to clip.
Quick Mask Mode

If Photoshop handles a selection as a grayscale channel, can’t you just work with it that way? You can if you switch to Quick Mask mode. Select the Quick Mask icon in the Tools panel or press Q; a red overlay indicates the Quick Mask. Solid areas of the mask are 50 percent opaque red, and the white (selected) areas are even more transparent than that. The red is supposed to remind you of Rubylith, if you remember the amber-colored acetate that was once cut up to create masks for film. One of the advantages of Quick Mask mode is that if you’re finding it a challenge to edit a selection with the marquee and lasso tools, in Quick Mask mode you can sculpt your selection using the brush and retouching tools.

Another advantage of Quick Mask mode is that you can actually see partially transparent pixels. In a typical selection, the selection marquee (also popularly called the marching ants) outlines the boundary of pixels that are selected 50 percent or more. There are often loads of other pixels that are selected 49 percent or less that you can’t see at all from the marching ants display. Quick Mask mode shows you exactly which pixels are selected and by how much.

A disadvantage of Quick Mask mode is that, like a marquee selection, it isn’t permanent. The Quick Mask goes away when you deselect, and it isn’t saved with the document. Choose Save > Save Selection to save it for later. Also, if you try to edit a Photoshop document and nothing happens, check to see whether the document is in Quick Mask mode; sometimes pressing the Q key by mistake.

While you’re in Quick Mask mode, a temporary Quick Mask channel appears in the Channels panel.

Customizing How a Quick Mask Appears. If you don’t like the red color that indicates a Quick Mask, double-click the Quick Mask icon in the Tools panel. You can change both the color and the transparency of the Quick Mask. You might want to increase the opacity of the color to about 75 percent so it displays more prominently against the background image.
Quick Mask view of a selection

Tip Select > Inverse won’t work on a Quick Mask because it consists of pixels, not a selection. To swap selected and unselected areas in Quick Mask mode, choose Image > Adjustments > Invert instead.

Using Photoshop Composite Images in Other Software

When you use a Photoshop composite image in other software, you may need to convert it to another file format. Exactly how you do this depends on whether you plan to use the composite Photoshop document as a normal graphic on a white background, or as an element in a composite in another program.

Should You Keep the Image in Photoshop Format?

You might be able to use your Photoshop composite image in other software without converting it. Some software, such as Adobe InDesign and Adobe After Effects, can directly use layered Photoshop format (PSD) documents, and may even let you work with individual Photoshop layers to a limited extent. InDesign lets you choose which layers or layer groups to make visible, while After Effects lets you independently animate individual layers. You may find it worth your while to research the applications where you plan to use your composite and see if you can simplify your workflow by not having to save a copy in a different format.
Exporting Without a Transparent Background

If you’re going to use a Photoshop composite as a single graphic on a white background, you don’t have to do anything special. Simply save the image in the format that you want, such as a JPEG. All layers will be flattened, and empty areas become white.

Exporting With a Transparent Background

Not all file formats can save a transparent background, so if you require that, you have to choose from the few formats that do support transparency.

To save an image with a transparent background:

1. Make sure the image is isolated from its background so that it’s surrounded by transparency in Photoshop, even if it’s just one layer.
   
   If you haven’t already done this, the rectangular background of the image may appear opaque white after you convert it to another format, even if that format supports transparency.
   
   Tip If the only layer in the image is the default Background layer, it has an opaque background that you must remove.

2. Choose File > Save As.

3. From the Format menu, choose a file format that supports transparency.
   
   For Adobe InDesign and professional printing, the best formats to use are Photoshop (.psd) and layered TIFF (.tif). For the web, PNG (.png) is the best format; GIF (.gif) can also be used but is much more limited.

4. Adjust other options as needed, and click Save.

   Note The popular JPEG (.jpg) file format doesn’t support transparency. In a JPEG file, empty areas are always white.

Exporting for the Web

These days, the standard format for preserving images with transparent backgrounds on web pages is PNG. While you might be aware that the older GIF format also provides for transparency, PNG is far superior because of a couple of important differences. GIF can only use 256 colors total, minus one color that’s used to mark transparent areas. PNG provides full RGB channels and an alpha channel for transparency, and all are 8 bits per channel. This means that with PNG you get millions of colors, and 256 levels of transparency that allow mask edges much smoother than you could ever achieve with GIF.

Where transparency comes into play on the web is when you want to composite a web page using CSS. One common example is using a large background image for the page, while positioning an image with a transparent background over the page.
When creating an image for the Web, it’s much better to use the Save for Web command instead of the Save As command. The Save As command is designed to save complete image information. The Save for Web command is designed to help you optimize an image for online use by giving you the option to remove thumbnail images and other metadata in order to keep the file size down, along with giving you tools to balance image compression quality against file size.

To save an image in PNG format:

1. Make sure the image is isolated from its background so that it’s surrounded by transparency in Photoshop, as I described in “Exporting With a Transparent Background.”
3. From the Preset pop-up menu in the top right corner, choose PNG-24.
4. Adjust other options as needed, and click Save.
5. Specify a filename and location, and click Save.

Exporting for Video

Some video-editing applications understand transparent objects and can composite them with video clips on a video timeline. This is certainly true for Adobe Premiere and Adobe After Effects, and for the video timeline in Photoshop.

All you have to do is follow the steps I described earlier in “Exporting With a Transparent Background” earlier, making sure to select the TIFF or PSD formats. If you’re using non-Adobe video software, check its help file to see what transparent still image formats it supports.
You love our books and you love to share them with your colleagues and friends...why not earn some $$ doing it!

If you have a website, blog or even a Facebook page, you can start earning money by putting a Peachpit link on your page.

If a visitor clicks on that link and purchases something on peachpit.com, you earn commissions* on all sales!

Every sale you bring to our site will earn you a commission. All you have to do is post an ad and we’ll take care of the rest.

APPLY AND GET STARTED!

It’s quick and easy to apply.
To learn more go to:
http://www.peachpit.com/affiliates/

*Valid for all books, eBooks and video sales at www.Peachpit.com