RapidWorks User Guide & Tutorial

The content of this manual is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by INUS Technology, Inc. Any names, places, and/or events in this publication are not intended to correspond or relate in any way to individuals, groups or associations. Any similarity or likeness of the names, places, and/or events in this publication to those of any individual, living or dead, place, event, or that of any group or association is purely coincidental and unintentional.

No warranties of any kind are generated or extended by this publication. Any products and related material disclosed in this publication have only been furnished pursuant and subject to the terms and conditions of a duly executed agreement to license the Software. Any warranties made by INUS Technology, Inc. with respect to the Software described in this publication are set forth in the License Agreement provided with the Software and printed in this publication. As more definitively stated and set forth in the License Agreement, INUS Technology, Inc. does not and will not accept any financial or other responsibility that may result from use of the Software or any accompanying material including, without limitation, any direct, indirect, special or consequential damages.

Individuals or organizations using the Software should ensure that the user of this information and/or the Software complies with the laws, rules, and regulations of the jurisdictions with respect to which it is used. This includes all applicable laws concerning the export of technology and the protection of intangible or intellectual property rights. INUS Technology, Inc. asserts its rights in and will endeavor to enforce all proprietary rights embodied in the Software and this publication including, without limitation, all copyright, patent, trademark, and trade secrets or proprietary information. The only rights given to an individual or organization purchasing the Software are those explicitly set forth in the License Agreement. Other than as explicitly allowed in the License Agreement, copying the Software or this material (including any format or language translation) is prohibited absent the prior written consent of INUS Technology, Inc.

INUS, INUS Technology, RapidWorks, Rapidform, Rapidform XOR, XOR, Rapidform XOV, XOV, Rapidform XOS, XOS, InspectWorks, Rapidform.dll, Rapidform DENTAL, Rapidform SURVEY, and the company logo and all product logos are either registered trademarks or trademarks of INUS Technology, Inc. All other trademarks within this user guide & tutorial are the property of their respective owners and are used for identification purposes only. Other than to identify this Software and publication, individuals or organizations purchasing the software are not entitled to use INUS Technology’s trademarks without INUS Technology’s prior written consent.

Correspondence regarding this publication should be directed to:

INUS Technology, Inc.
1. Introduction

This tutorial is intended for users who need to become quickly familiar with RapidWorks. Before getting into the detailed instructions for using RapidWorks, this step-by-step tutorial aims at giving you a feel for what you can accomplish with the product.

This tutorial will guide you completely design a watertight mesh model using powerful mesh modeling Tools. You will learn about the mesh modeling methods that can create a watertight mesh model from a set of 3D scan data.

Training time required: approx. 30 min.
Level of Difficulty: Basic

2. Data Files

Mesh_Optimization.rwl – a set of scanned mesh data of a helmet model.
Download: http://nextwiki.s3.amazonaws.com/resources/application/octet-stream/659cb9c0a2da012f2eb600254b9c869c-g1qdiiny87pzi.rwl

The sample data for this tutorial is provided by INUS Technology. They are the property of INUS Technology and are used for informational purposes only. Other than to identify this software and publication, individuals or organizations purchasing the software are not entitled to use the sample data without INUS Technology's prior written consent.
3. Overview

What will you learn in this course?
- Remove noises from a set of scan data
- Align meshes
- Merge meshes into a single mesh
- Heal defects from a mesh
- Enhance quality of a mesh
- Optimize a mesh

What will you learn to do in this course?
- You can easily and quickly create a single mesh from a set of scanned meshes by using Mesh Buildup Wizard.
- You check defects in the mesh and heal the defects from the mesh by using Healing Wizard.
- If the mesh has some missing holes, you can easily fill the holes by using Fill Holes and Rewrap commands.
- You can finally enhance quality of the mesh and optimize it.

What does this exercise cover?

<table>
<thead>
<tr>
<th>Step 1. Import Scan Data and Run Mesh Buildup Wizard</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can import a set of scanned meshes as target scan data into the application and run Mesh Buildup Wizard to create a single mesh from them.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2. Create Single Mesh from A Set of Scanned Meshes</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can easily and quickly create a single mesh from a set of scanned meshes by using Mesh Buildup Wizard.</td>
</tr>
<tr>
<td>Step 3. Heal Defects</td>
</tr>
<tr>
<td>----------------------</td>
</tr>
<tr>
<td>You can check defects in the mesh and heal the defects from the mesh by using Healing Wizard.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 4. Fill Holes</th>
<th>![Image of a helmet]</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can easily fill some missing holes in the mesh by using Fill Holes and Rewrap commands.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 5. Enhance Quality of Mesh and Thicken Mesh</th>
<th>![Image of a helmet]</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can enhance the quality of the mesh and thicken the mesh.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 6. Optimize Mesh and Check Result</th>
<th>![Image of a helmet]</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can finally optimize the mesh and check the modeling result.</td>
<td></td>
</tr>
</tbody>
</table>
4. Modeling Process

Step1. Import Scan Data and Run Mesh Buildup Wizard

In this step, you will learn how to import a set of scanned meshes as target scan data into the application and run Mesh Buildup Wizard to create a single mesh from them.

1. Import Scan Data and Run Mesh Buildup Wizard

Follow this step by using the Mesh_Optimization_01-19.stl files.

① Click the File Import in the Toolbar or choose Insert > Import in the menu.
② Select the scanned mesh files (Mesh_Optimization.rwl) and click the Run Mesh Buildup Wizard button.

Download: http://nextwiki.s3.amazonaws.com/resources/application/octet-stream/659cb9c0a2da012f2eb600254b9c869c-g1qdiiny87pzi.rwl

Tip. You can easily select a set of scanned meshes with 'Shift' key

③ Check that a set of scanned meshes are imported into the application in the Model View.
Step 2. Create A Single Mesh from A Set of Scanned Meshes

You have imported a set of scanned meshes into the application and run Mesh Buildup Wizard to create a single mesh from them so far.
In this step, you will learn how you can easily and quickly create a single mesh from a set of scanned meshes by using Mesh Buildup Wizard.

1. Data Preparation

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-Fit Aligning, and Data Merging.

In the first stage, you can choose a scanner type which you have used to scan a target object.
① Check that all imported meshes are registered as the target scan data in the Select option.

![Select]

**Note.** You can also check the imported meshes in the Entity Thumbnails View. If you move your mouse cursor over the one of entities in the Entity Thumbnails View, a small widow pops up and you can check each one of imported meshes in the window, as shown in the image below.

![Entity Thumbnails View]

Rotate, Pan and Zoom-In/Out are available in the window.

② Check the **Small/Medium Size Object Scanner** option in the Set Scanner Type.

**Note**

*Mesh Buildup Wizard* provides different parameters and options during the process according to your definition of scanner type. This tutorial will use the **Small/Medium Size Object Scanner** type for the helmet model.

③ Turn the other options off in the Set Data Condition, as shown in the image below.
2. Data Editing

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-Fit Aligning, and Data Merging.

In the second stage, you can edit the meshes. If the meshes have some noises or you have picked up some floor poly-faces while scanning, then you can remove those unwanted areas in this stage.

**Note.** Mesh Buildup Wizard provides several editing tools in the second stage. You can manually select some unwanted areas in the meshes and delete the areas as well as you can easily find noisy clusters from the meshes and remove the noises. If you think that the meshes have no noises, you can skip this stage. Even if you skip this stage, note that you can edit the meshes whenever you need to edit them because these editing tools will be available in different stage as well.

1. Click the Find Floor button to find floor poly-faces in the meshes.
2. Select a point on the planar area of the mesh as a seed point to find planar floor poly-faces, as shown in the image below.

   ![Image](image1.png)

   **Note.** Just pick a point on the mesh and then Mesh Buildup Wizard automatically finds the planar floor poly-faces in the mesh by using the seed point even though the mesh has complex freeform feature shapes. The Find Floor button can be toggled on / off. So, you can continuously find floor poly-faces from the other meshes.

3. Continue selecting points on the planar area of the other meshes, as shown in the image below.

   ![Image](image2.png)

4. Click the **Delete Selected Entities (Delete)** button.
5. Check the result in the Model View or in the Entity Thumbnails and toggle off the **Find Floor** button.
6. Set the **Max. Poly-Vertices/Faces Count Per Noisy Cluster** to 100.
7. Click the **Find Noisy Cluster** button to find noisy clusters from the meshes.
Mesh Buildup Wizard automatically detects small clusters which are nothing but groups of poly-faces whose poly-faces count is smaller than the defined Max. Poly-Vertices/Faces Count Per Noisy Cluster. After the small clusters are selected, you can remove them by clicking the Delete Selected Entities (Delete) button or 'Delete' key.

8. Check the selected small noisy clusters in the Select list, as shown in the image below.

9. Click the Delete Selected Entities (Delete) button.
10. Check the result and then click the Next Stage button to continue.

3. Data Pre-Aligning

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-Fit Aligning, and Data Merging.

In the third stage, you can approximately align meshes.

Note. Mesh Buildup Wizard provides two different alignment methods such as Local Based On Auto Guess and Local Based On Picked Point in the third stage. The Local Based On Auto Guess method is the one of methods in the third stage which allows you to easily align the meshes no matter where the meshes are. The meshes are automatically aligned with each other by using the geometric shape information. The Local Based On Picked Point method is the other method which allows you to manually align the meshes by picking several corresponding points on the meshes.
① Check the **Local Based On Auto Guess** in the Method.
② Check that all the meshes are registered as the target meshes in the Moving.
③ Set the **Preference** to the middle in the Slide bar and adjust the options, as shown in the image below.

![Image of Mesh Buildup Wizard](image)

**Tip.** If you set the Preference to the Speed, the alignment will be quickly done. But the alignment result may be incorrect if the shapes of meshes are simple. That means if there are no geometric feature shapes on the meshes which can constraint each other then it becomes difficult to align them with this option setting.

If you set the Preference to high Quality, Mesh Buildup Wizard will try to align the meshes as close as possible by using the geometric shape information. But, the alignment process may take a long time.

④ Click the **Apply** button and check the result.

![Image of Meshes in which the normal direction has been reversed](image)

**Note**
All the meshes are automatically aligned, but some meshes are still not aligned as you can check in the result.
If normal direction of meshes has been reversed or some noises are still there in the meshes, then the automatic alignment may not be completely done.

In this case, you can manually edit these meshes by using the **Edit Tools** as you did in the previous stage and then you can manually align the modified meshes with the aligned meshes by using the **Local Based On Picked Point method**.

⑤ Pull down the **Edit Tools** by clicking the option.
⑥ Click the **Reverse Normal Of Entire Mesh/Point Cloud** button to reverse the normal direction of meshes.
Select the meshes (Mesh_Optimization_01) whose normal direction has been reversed, as shown in the image below.

Tip. If you find it difficult to locate the meshes whose normal direction has been reversed, then you can change the display color for their back face.
You can change the display color for the back side of meshes in the Back Face option under the General section in the Display tab.

Check the result, as shown in the image below.

If you change the display color in the Back Face option to 'User Defined', the color of back side of meshes will be changed to the color you define/pick.
You can also define the color under the display tab in Preferences (File > Preferences).
Note. Check if floor poly-faces are still remained. If so, delete the poly-face as follows:

i. Select the **Delete Floor** button and then select a point on the mesh as a seed point to find planar floor poly-faces, as shown in the image below.

ii. Click the **Delete Selected Entities (Delete)** button.

9. Return back to the alignment process by clicking the **Method** option.
10. Check the **Local Based On Picked Point** option.
11. Select the aligned meshes to register them to the **Reference** and click the **Moving** button to register the other meshes to the Moving.
12. Select the other meshes as the target Moving meshes, as shown in the image below.
13. Pick corresponding points on the Reference meshes and the Moving meshes in the each Model View in consecutive order, as shown in the image below.

**Note.** At least three corresponding points are needed to accurately align the Moving meshes to the Reference meshes.

**Tip.** If you want to cancel the last picked corresponding point, then you undo the operation by using "Edit > Undo" or clicking 'Ctrl + Z' key.

14. Click the **Apply** button.

**Note.** After the operation is completely done, the aligned moving meshes are automatically registered as the Reference. If you need to align the other meshes to the Reference meshes, you can continue to apply the alignment to the meshes, same as the previous step.

15. Check the result and click the **Next Stage** button to continue.
4. Best-Fit Aligning

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-Fit Aligning, and Data Merging.

In the fourth stage, you can accurately align meshes.

**Note.** All the meshes have been approximately aligned each other. Now, you can accurately align the meshes.

1. Click the **Moving** button to register the meshes as the target Moving meshes and select all the meshes.
2. Turn all options off in the Options, as shown in the image below.
3. Click the **Apply** button.

**Note.** All the meshes will be accurately aligned.

4. Check the deviation between the aligned meshes by selecting the Max./Min./Avg. Deviation button in the Accuracy Analyzer(TM).
**Tip.** You can check how the meshes are accurately aligned to each other by using the Accuracy Analyzer(TM). And if you move your mouse cursor over one of meshes in the Entity Thumbnails, you can also check a deviation between the specific mesh and the others.

5. **Click the Next Stage button.**

5. **Data Merging**

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-Fit Aligning, and Data Merging.

Finally, you can merge the aligned meshes into a single mesh.

**Note.** All the meshes have been accurately aligned to each other. Now, you can merge all the meshes into a single mesh. This is the final stage of Mesh Buildup Wizard.

1. Adjust the Geometry Capture Accuracy option, as shown in the image below.
② Click the **Apply** button.

③ Check the result.

---

**Note.** *All the meshes are completely merged into a single mesh.*

④ Click the **OK** button to close the Mesh Buildup Wizard.
Step 3. Heal Defects

You have created a single mesh from a set of scanned meshes by using Mesh Buildup Wizard so far. In this step, you will learn how to check defects in the mesh and heal the defects on the mesh by using Healing Wizard.

1. Heal Defects

Now, you can optimize the mesh. In the first step of optimization process, you can check defects on the mesh and you can fix it.

**Note.** When the meshes which have been scanned in different directions by using 3D scanner are aligned and merged with each other, some defects such folded poly-faces, dangling poly-faces, small noisy clusters, etc. may occur in the merged mesh. To optimize the mesh, first you need to heal the defects on the mesh.

① Select the generated mesh in the Feature Tree or in the Model Tree and click the Mesh button in the Tool Palette to optimize the mesh in the Mesh mode.

**Tip.** You can also enter the Mesh mode to optimize the mesh by double clicking the generated mesh in the Feature Tree or in the Model Tree.

② Click the Healing Wizard in the Toolbar or choose **Tools > Mesh Tools > Healing Wizard** in the menu.

③ Check the defects on the mesh.
Note. Healing Wizard automatically detects defects in the mesh and also displays them with highlighted colors on the mesh.

Tip. Folded Poly-Faces
This option will be automatically checked when some poly-faces have been folded together on the same place. It will remove these poly-faces.

- Dangling Poly-Faces
  This option will be automatically checked when 2 or 3 open side poly-faces are hanging on the boundary of mesh, as shown in the image below.

  ![2 side opened poly-face](image1)
  ![3 side opened poly-face](image2)

  It will remove these poly-faces.

- Small Clusters
  This option will be automatically checked when small clusters (a group of connected poly-faces) which have less poly-faces than the specified number of poly-faces are detected in the mesh, as shown in the image below.

  ![Small Clusters](image3)

  It will remove these poly-faces.

- Small Poly-Faces
  This option will be automatically checked when small poly-faces whose area is smaller than the specified area are detected in the mesh, as shown in the image below.

  ![Small Poly-faces](image4)

  It will remove these poly-faces.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Non-Manifold Poly-Faces</strong></td>
<td>This option will be automatically checked when some non-manifold poly-faces or redundant poly-faces are detected in the mesh. It will remove these poly-faces.</td>
</tr>
<tr>
<td><strong>Crossing Poly-Faces</strong></td>
<td>This option will be automatically checked when some crossing poly-faces are detected in the mesh. Healing Wizard provides three different healing methods such as Smooth, Merge Poly-Vertices, and Delete And Fill Hole in the option.</td>
</tr>
<tr>
<td></td>
<td>- The <strong>Smooth</strong> which is one of the methods smoothly regenerates poly-faces around the crossing poly-faces.</td>
</tr>
<tr>
<td></td>
<td>- The <strong>Merge Poly-Vertices</strong> which is another method merges poly-vertices around the crossing poly-faces.</td>
</tr>
<tr>
<td></td>
<td>- The <strong>Delete And Fill Hole</strong> which is the other method removes poly-faces around the crossing poly-faces and fills the resulting holes.</td>
</tr>
<tr>
<td><strong>Small Tunnels</strong></td>
<td>This option will be automatically checked when some poly-faces whose shape is like a tunnel or handle are detected in the mesh. It will remove these poly-faces.</td>
</tr>
</tbody>
</table>

4. Click the **OK** button.
5. Check the result.

*Note.* All the detected defects are removed from the mesh.
Step 4. Fill Holes

You have checked defects in the mesh and healed the defects from the mesh by using Healing Wizard so far. In this step, you will learn how you can easily fill some missing holes in the mesh by using Fill Holes and Rewrap command.

1. Fill Holes

In the second step of optimization process, you can fill holes and create a closed volume mesh.

1. Click Fill Holes in the Toolbar or choose Tools > Mesh Tools > Fill Holes in the menu.

**Note.** You need to fill the holes to create a high quality volume mesh.

**Tip.** If you feel that it’s difficult to find missing holes in mesh, you can easily find the holes by changing the displayed color for the boundaries of mesh. You can change the displayed color for the boundaries of mesh in the Boundary option under the Mesh/Point Cloud section in the Display tab.
Check the Method is **Curvature** and click the **Add Bridge** button to create a bridge between the poly-edges in the hole.

**Note.** If a hole is big or complex to fill, the bridge helps you to divide the big hole into several small holes and easily fill the holes.

Select the poly-edge in the left side of the boundary and drag the bridge to the other poly-edge in the right side of the boundary, as shown in the image below.

Add a bridge between the other poly-edges, same as the previous step.
5. Click the **Boundaries** button and then select the divided boundaries, as shown in the image below.

6. Check the **Smooth Boundary** option in More Options
7. Click the **Preview** button and check the previewed result.

8. Click the **Accept** button.

2. **Wrap Entire Mesh**

When the mesh has too many holes and the holes are complex and difficult to manually fill, you can easily fill the holes at one shot by using Rewrap function.

1. Check the Rewrap in the Toolbar or choose **Tools > Mesh Tools > Rewrap** in the menu.

*Note. Rewrap allows you to wrap the entire mesh. You can easily create a closed volume mesh even*
though the mesh has complex holes and missing feature areas.

2 Adjust options, as shown in the image below.

Tip. You can check the current average poly-edge length. If you set the Edge Length Multiplier to ‘1’, the mesh will be rewrapped with current average poly-edge length. If you set the Edge Length Multiplier to ‘2’, the mesh will be rewrapped with average poly-edge length which is two times bigger than current average poly-edge length.

3 Click the Preview button.

Note. You can see that all the holes are completely filled in the preview result.

4 Check the previewed result and then click the Accept button.

Tip. You can completely fill the holes in the mesh by using Rewrap command, but if the mesh has some obviously big missing feature areas, then apply the Rewrap command to the mesh after adding any bridges in the Fill Holes command. You will then get a better result.
Step5: Enhance Quality of Mesh and Thicken Mesh

You have filled holes in the mesh by using Fill Holes and Rewrap command so far. In this step, you will learn how you can enhance the quality of the mesh and thicken the mesh.

1. Enhance Quality of Mesh

You can enhance the quality of the mesh.

① Click the Enhance Shape in the Toolbar or choose Tools > Mesh Tools > Enhance Shape in the menu.

*Note*: Enhance Shape command allows you to enhance typical feature shapes in the mesh. The low curvature areas will become much smoother and high curvature areas will become much sharper in the mesh.

② Set the Sharpness to the middle and the Overall Smoothness to Max, as shown in the image below.

*Note*: You can adjust the weight of the sharpness and the overall smoothness by controlling the slide bar.
and you can also set the iteration of those enhancements by controlling the Enhance Level.

3. Click the **Next Stage** button to continue.

**Note.** You can adjust the iteration of the enhancements in the second stage of the Enhance Shape command while you preview the result.

4. Check the previewed result and then click the **OK** button.

2. **Thicken Mesh**

You can also thicken the mesh.

**Note.** Currently, the mesh is constructed by poly-faces as a shell.
You can create a volume mesh which has constant thickness by using Thicken command.

① Click the **Thicken** in the Toolbar or choose **Tools > Mesh Tools > Thicken** in the menu.
② Check the **Surface** option in the Method.

**Note.** Thicken command provides two different methods. The Surface method is one of the methods which expands or reduces the poly-faces in the mesh and creates new offset poly-faces which are at specific distance away from the original mesh. The Volume method is other method which constructs voxel structure that consists of 3D lattices with uniform length from the mesh and creates new offset poly-faces which are away from the poly-vertices by the size of the voxel.

③ Set the **Thickness** to **3mm** and then check the **Direction2**, as shown in the image below.
Note. The offset direction is based on the normal direction of the mesh. The Direction1 is same as the normal direction of the mesh and the Direction2 is opposite to the normal direction of the mesh. You can also thicken the mesh in the both directions.

4. Click the Preview button.

5. Check the previewed result and then click the Accept button.

Note. Now, the mesh with predefined thickness is completely generated.
Tip. You can also check the thickness of mesh by using View Clip (View > View Clip).
Step 6: Optimize Mesh and Check Result

In this step, you can finally optimize the mesh and check the result.

1. Optimize Mesh

Finally, you can optimize the mesh.

① Click the **Optimize Mesh** in the Toolbar or choose **Tools > Mesh Tools > Optimize Mesh** in the menu.

*Note.* Finally, you can highly improve the quality of the mesh by using the Optimize Mesh command. The Optimize Mesh command re-triangulates the poly-faces in the mesh and improves the quality of the mesh. The size of the poly-faces in the mesh will vary according to feature shapes on the mesh.

② Check the **High Quality Mesh Conversion** option in the Method.
③ Set the Min. Edge Length Multiplier to **0.5** and then set the Max. Edge Length Multiplier to **3**, as shown in the image below.
Note. Poly-faces in the mesh will be automatically reconstructed according to feature shapes on the mesh, using the defined Min. Edge Length to the Max. Edge Length.

4. Click the Preview button.

5. Check the previewed result and then click the Accept button.

2. Check Optimized Result

Finally, you can check the optimized result.

① Check the result with Accuracy Analyzer(TM).

Note. Finally, you can find the deviation between the optimized mesh and the original mesh with the Accuracy Analyzer(TM).
**Note.** You can also check the quality of the optimized mesh with the Accuracy Analyzer(TM).